Search found 3 matches

by ProudPagan
Tue Feb 21, 2017 8:29 am
Forum: All other boards
Topic: Getting Blinky to work on STM32 Value line Discovery board STM32F100RB
Replies: 5
Views: 774

Re: Getting Blinky to work on STM32 Value line Discovery board STM32F100RB

Pito wrote:Did you compile for "Upload method STLink" ?
Yes, I see only STLink as the upload method -- and I used that. I see lights on the board flashing for a few seconds, so I think upload
is done correctly.


Thanks for all help.

--PP
by ProudPagan
Thu Feb 16, 2017 5:16 am
Forum: All other boards
Topic: Getting Blinky to work on STM32 Value line Discovery board STM32F100RB
Replies: 5
Views: 774

Getting Blinky to work on STM32 Value line Discovery board STM32F100RB

Hi All, I have used the Arduino framework+IDE for AVR and ESP8266, but can't get a blinky to work on the STM32 Value Line Discovery board STM32F100RB. I have 2017.1.20 version of STM32F1xx Core installed. I see the code correctly compiled, linked and uploaded to the board: STM32 ST-LINK CLI v2.1.0 S...
by ProudPagan
Wed Feb 15, 2017 4:52 am
Forum: All other boards
Topic: Value Line Discovery Board
Replies: 45
Views: 2691

Re: Value Line Discovery Board

Hello Phisatho, Could you provide the code that you used? I can compile and what seems like upload the blinky sketch correctly -- see below -- but see no blinking LEDs. STM32 ST-LINK CLI v2.1.0 STM32 ST-LINK Command Line Interface ST-LINK SN : ST-Link/V1 on E: ST-LINK Firmware version : V1J11S0 (Nee...