Search found 61 matches

by vitor_boss
Wed Aug 30, 2017 10:38 pm
Forum: PR's bugs and enhancements
Topic: Update texane stlink
Replies: 14
Views: 268

Re: Update texane stlink

I put the folder on D: and had installed all related tools.

Thank you for your time.
by vitor_boss
Wed Aug 30, 2017 1:06 pm
Forum: PR's bugs and enhancements
Topic: Update texane stlink
Replies: 14
Views: 268

Re: Update texane stlink

No, my Windows is 10 Pro x64
Image
by vitor_boss
Wed Aug 30, 2017 11:19 am
Forum: PR's bugs and enhancements
Topic: Update texane stlink
Replies: 14
Views: 268

Re: Update texane stlink

No, I did everything needed but always return error. mingw64-build.bat: @echo off set PATH=C:\Program Files (x86)\CMake\bin;C:\Program Files\CMake\bin;C:\Program Files\mingw-w64\x86_64-7.1.0-win32-sjlj-rt_v5-rev2\mingw64\bin;%PATH% cmake -G "MinGW Makefiles" .. mingw32-make mingw32-make install DEST...
by vitor_boss
Wed Aug 30, 2017 11:11 am
Forum: IDE's
Topic: Debug STM32 with VScode
Replies: 28
Views: 1471

Re: Debug STM32 with VScode

@vitor_boss How i did it on Windows 10. Tested with ST-Link & Bluepill. 1.) Download and install "Arduino": https://www.arduino.cc/en/Main/Software 2.) In Arduino "Boards Manager" install "Arduino SAMD Boards", not "Ardiuno SAM Boards"!!! 3.) Download rogerclarkmelbourne's repo: https://github.com/...
by vitor_boss
Wed Aug 30, 2017 1:50 am
Forum: IDE's
Topic: Debug STM32 with VScode
Replies: 28
Views: 1471

Re: Debug STM32 with VScode

iamseer wrote:
Wed Jul 19, 2017 7:58 pm
Happy debugging!
7_debug.jpg
Maybe I missed something, I follow all the steps and cant get it running.
Could you help?
by vitor_boss
Tue Aug 29, 2017 8:50 pm
Forum: PR's bugs and enhancements
Topic: Update texane stlink
Replies: 14
Views: 268

Re: Update texane stlink

Hi, @vitor_boss I've built the texane stlink 1.4.0 for Windows (64bits), it is available here if you want make a try https://github.com/fpistm/stm32_tools/raw/beeda1bcb8ad04d0fea6b69def045ebae6df1502/stlink-1.4.0-win64.zip It's alive, worked like a boss. Thank you. You will include and let it defau...
by vitor_boss
Mon Aug 28, 2017 8:51 pm
Forum: PR's bugs and enhancements
Topic: Update texane stlink
Replies: 14
Views: 268

Re: Update texane stlink

fpiSTM wrote:
Mon Aug 28, 2017 8:46 pm
Fix in 1.3.1 is mainly for build. Not required as we provide the binary. I do not compile it for windows as we provide st-link utility for windows.
I mainly shared for script update as there are the same for linux/MacOs ;)
st-link utility for windows don't work with st-link clones but texane's do
by vitor_boss
Mon Aug 28, 2017 8:32 pm
Forum: PR's bugs and enhancements
Topic: Update texane stlink
Replies: 14
Views: 268

Re: Update texane stlink

I've made the job here for the 1.3.0 https://github.com/stm32duino/Arduino_Tools/commit/50fa24ba2e7e3d0fb24aca46c6c5d2ab4af1f14e It could help as it's based on the same script. Main issue was for the library path. My knowledge in C is very small, I have downloaded Cygwin64 to try compile it for win...
by vitor_boss
Mon Aug 28, 2017 6:46 pm
Forum: PR's bugs and enhancements
Topic: Update texane stlink
Replies: 14
Views: 268

Update texane stlink

I bought a ST-Link clone from Aliexpress and it works with STM32 ST-LINK Utility but couldn't upload on arduino. After some digging I found texane stlink utility inside libraries, but is only 4 years outdated(v0.5.6), after download the last version (1.3.0) compiled for windows(I try but don't succe...
by vitor_boss
Sat Aug 26, 2017 6:17 pm
Forum: IDE's
Topic: Debug STM32 with VScode
Replies: 28
Views: 1471

Re: Debug STM32 with VScode

Guys, I really need help here, when I try to start debugger give error "Unable to start debugging. Nenhum processo associado a este objeto."

What I'm doing wrong?

STM32 ST-LINK works fine, but upload via st-link don't work