Search found 27 matches

by oneselflost
Thu Nov 02, 2017 11:10 am
Forum: STM Core
Topic: SensorTile
Replies: 25
Views: 764

Re: SensorTile

I am powering via USBVDD - The LED does work when the ST ALLMEMS1 example is loaded.
by oneselflost
Thu Nov 02, 2017 2:34 am
Forum: STM Core
Topic: SensorTile
Replies: 25
Views: 764

Re: SensorTile

I tried code to use the ST HAL directly, and sure enough, it didn't work. Looking through the schematic and the MEMS example provided by ST, it looks like the SAI_SD is connected to an audio chip. That said, I am leaving alone PG12 for now :lol: Moving along though - PC0, PC1, and SWD pins all blink...
by oneselflost
Wed Nov 01, 2017 7:04 pm
Forum: STM Core
Topic: SensorTile
Replies: 25
Views: 764

Re: SensorTile

I toght you've put PG_12 next to PG12 in variant.h
- No, those are comments next to the PxX in variant.h
Did you add PG12 in variant.h before PEND ?
- Yes
by oneselflost
Wed Nov 01, 2017 6:39 pm
Forum: STM Core
Topic: SensorTile
Replies: 25
Views: 764

Re: SensorTile

Just added "PG12" to the bottom of the extern const PinName digitalPin[] array in variant.h, and "PG_12" to the bottom of that in variant.cpp (which you mentioned I won't need, I'll try it without that in the cpp tonight)
by oneselflost
Wed Nov 01, 2017 5:03 pm
Forum: STM Core
Topic: SensorTile
Replies: 25
Views: 764

Re: SensorTile

I am using the NUCLEO_L476RG variant - haven't made my own yet. Tried the PG_12 yesterday, same results - compiles but doesn't do anything. The LED is definitely tied to PG12 too, here is the schematic: http://www.st.com/content/ccc/resource/technical/layouts_and_diagrams/schematic_pack/group0/dd/ce...
by oneselflost
Wed Nov 01, 2017 3:06 pm
Forum: STM Core
Topic: SensorTile
Replies: 25
Views: 764

Re: SensorTile

Hmm.. Do you think because I added it to the .cpp file that would have any negative effect on it?

I'll have to play with it once I get home.
by oneselflost
Wed Nov 01, 2017 2:48 pm
Forum: STM Core
Topic: SensorTile
Replies: 25
Views: 764

Re: SensorTile

I tried with PG_12 in the sketch, that compiled without error as well, but did not work either. Also added a #define LED2 PG_12, and used LED2 in the sketch, that also compiled without error, but did not work either. I added PG_12 to variant.cpp, and PG12 to variant.h, in the same position of the re...
by oneselflost
Wed Nov 01, 2017 2:26 pm
Forum: STM Core
Topic: SensorTile
Replies: 25
Views: 764

Re: SensorTile

It compiles without error
by oneselflost
Wed Nov 01, 2017 1:19 pm
Forum: STM Core
Topic: SensorTile
Replies: 25
Views: 764

Re: SensorTile

Thank you so much for replying, and pointing me to those files. Well if the GPIOG clock is already enabled, then I am at a loss for why this pin will not blink. I am using the blink example, and it compiles and flashes without error. void setup() { pinMode(PG12, OUTPUT); } void loop(){ digitalWrite(...
by oneselflost
Wed Nov 01, 2017 2:15 am
Forum: STM Core
Topic: SensorTile
Replies: 25
Views: 764

Re: SensorTile

I'm at a point where I think the issue preventing PG12 from blinking might be a clock enable on GPIOG, as you mentioned prior - but I can't for the life of me find where this is enable is implemented. Where would I go about to make this happen?

Enjoy your vacation!