Search found 1157 matches

by zmemw16
Mon Jun 26, 2017 10:29 am
Forum: General discussion
Topic: Should we still use optimisation level -Os (Small)
Replies: 15
Views: 189

Re: Should we still use optimisation level -Os (Small)

can't we just default it to -Os ? as now in effect, let user then change it if reqd.
srp
by zmemw16
Sat Jun 24, 2017 11:20 am
Forum: Projects
Topic: OV7670, Generic STM32F103RC and ILI9341 display
Replies: 84
Views: 6483

Re: OV7670, Generic STM32F103RC and ILI9341 display

that would be oh so much easier with a ',BIN' in the println :D
srp
by zmemw16
Sat Jun 24, 2017 12:41 am
Forum: General discussion
Topic: SD card on ILI9341 display board??
Replies: 17
Views: 215

Re: SD card on ILI9341 display board??

can i ask for before & after pics?
srp
by zmemw16
Fri Jun 23, 2017 10:06 am
Forum: Welcome & FAQs
Topic: Saying hello from turkey
Replies: 7
Views: 127

Re: Saying hello from turkey

wrap the code you the '</>' button above the compose window.

Code: Select all

my line of code
you may wish to try google with 'HX711 stm32', 1st & 3rd results look to be likely candidates for further investigation.
stephen
by zmemw16
Fri Jun 23, 2017 10:00 am
Forum: CubeMX and HAL
Topic: change stm32f411 to stm32f401 in cubemx project
Replies: 0
Views: 32

change stm32f411 to stm32f401 in cubemx project

ok, so who would :D

i found some 411 based stuff and wondered if / how to change the processor ?
i think hand editing the ioc is not quite the right way to do it, unless its really simple of course :!: .

stephen
by zmemw16
Fri Jun 23, 2017 8:37 am
Forum: Problems with libraries
Topic: Arduino TFT libraries compatibility
Replies: 16
Views: 233

Re: Arduino TFT libraries compatibility

oh no it isn't :)
sorry
stephen
by zmemw16
Fri Jun 23, 2017 1:29 am
Forum: General discussion
Topic: useful usb-ser-mon python script
Replies: 1
Views: 44

useful usb-ser-mon python script

whilst pursuing my Black ZGT's usb port, udev is not top of my list either
anyone else found this one before?
https://github.com/dhylands/usb-ser-mon
stephen
by zmemw16
Tue Jun 20, 2017 5:53 pm
Forum: Generic STM32F103
Topic: Solved: I2C2 on STM32F103C8T6 and HWire
Replies: 38
Views: 655

Re: I2C2 on STM32F103C8T6 and HWire

thought i'd posted this already
constructor has a defaulted parameter for the mode

Code: Select all

HardWire HWire(2, I2C_FAST_MODE); // I2C2
HardWire HWire(2); // I2C2 slow mode
srp
by zmemw16
Mon Jun 19, 2017 1:40 pm
Forum: Generic STM32F103
Topic: Solved: I2C2 on STM32F103C8T6 and HWire
Replies: 38
Views: 655

Re: I2C2 on STM32F103C8T6 and HWire

software i2c must be slower than HW fast mode, so try HW slow mode ?
srp
by zmemw16
Sun Jun 18, 2017 6:32 am
Forum: Maple mini
Topic: MM board not detected on one machine.
Replies: 4
Views: 126

Re: MM board not detected on one machine.

you may want to check the /dev/ directory for ttyACM* and ttyUSB entries. mine appear correctly from a cold boot on Debian Jessie 8.x 64 bit, but I quite regularly have to unplug all (STLink, 2 FTDI usb, Openbench Logic sniffer, UUT) and slowly re-insert them into the hub, whilst 'watch comms' is ru...