Search found 6716 matches

by RogerClark
Mon Sep 25, 2017 8:11 am
Forum: New users MUST post here first, and let us know a bit about you and your projects
Topic: trouble with timers and library structure
Replies: 8
Views: 48

Re: trouble with timers and library structure

I think this is the environment: Arduino: 1.6.9 (Windows XP), Board: "Discovery, STM32F100RB-DISCVL, STLink, None, None" Arduino 1.6.9. should work ok. Upload via ST-Link (V2?). Just wondering, the Arduino_STM32 core does not have any variant named "Discovery, STM32F100RB-DISCVL". Which target did ...
by RogerClark
Mon Sep 25, 2017 8:09 am
Forum: Projects
Topic: OV7670, Generic STM32F103RC and ILI9341 display
Replies: 314
Views: 11745

Re: OV7670, Generic STM32F103RC and ILI9341 display

I had a bug in the code I posted // // Created by indrek on 4.12.2016. // // Adapted for ILI9341 by stevestrong on 29.07.2017 // #include <LiveOV7670_stm32_OK.h> #include <Adafruit_ILI9341_STM.h> #include <SdFat.h> const uint8_t SD_CS = PC15; SdFat sd; // TFT connection: // PB1 - TFT reset // PA2 - ...
by RogerClark
Mon Sep 25, 2017 5:33 am
Forum: New users MUST post here first, and let us know a bit about you and your projects
Topic: trouble with timers and library structure
Replies: 8
Views: 48

Re: trouble with timers and library structure

Welcome Frank I've just tried to compile that example and I'm not getting any errors I tried 2 different boards the Generic STM32F103C and also the Nucleo F103RB The only difference I can see if that you are using quite an old version of the Arduino IDE (1.6.9) where as I'm using 1.8.3 (It looks lik...
by RogerClark
Mon Sep 25, 2017 5:12 am
Forum: Black Magic Probe & other
Topic: [Solved] Conversion of Not so good value STM32F103C8T6 Board to BMP
Replies: 14
Views: 129

Re: Conversion of Not so good value STM32F103C8T6 Board to BMP

@flodejr

Sorry. I miss-read the title.

I think you'd be better off going onto the BMP chat room on Gitter

https://gitter.im/blacksphere/blackmagic

Those guys know a lot more about building the BMP etc
by RogerClark
Mon Sep 25, 2017 2:58 am
Forum: Black Magic Probe & other
Topic: [Solved] Conversion of Not so good value STM32F103C8T6 Board to BMP
Replies: 14
Views: 129

Re: Conversion of Not so good value STM32F103C8T6 Board to BMP

I think you may be making life difficult for yourself If you select the "generic stm32f103c" board in the Arduino IDE, then select STLink upload it will upload via STLink There is also an option to use the Blackmagic probe if you have one of those. There is however a difference in how the board will...
by RogerClark
Mon Sep 25, 2017 1:44 am
Forum: Maple & Maple mini etc
Topic: Maple Mini clone (Baite) schematics
Replies: 2
Views: 51

Re: Maple Mini clone (Baite) schematics

@pito

Thanks.

I've added that image to the Wiki
by RogerClark
Sun Sep 24, 2017 11:38 pm
Forum: Builds and Announcements
Topic: New registratiion rules to reduce bot registration
Replies: 5
Views: 123

Re: New registratiion rules to reduce bot registration

does being marked as new users affect their reading or downloading attachment privileges ? if it doesn,t then mark them as new users; in effect that's what they are as they haven't posted anything. stephen BTW. Running some other analysis on the site, your GeoIP location does not match the location...
by RogerClark
Sun Sep 24, 2017 11:33 pm
Forum: Builds and Announcements
Topic: New registratiion rules to reduce bot registration
Replies: 5
Views: 123

Re: New registratiion rules to reduce bot registration

I just changed it so that they can't post.

They can still view the whole site and also download any attachments, etc

Note.

The "newusertest" is me. I had to create a new user who has not posted, so that I can test what a new user can and cant do.
by RogerClark
Sun Sep 24, 2017 11:14 pm
Forum: Builds and Announcements
Topic: New registratiion rules to reduce bot registration
Replies: 5
Views: 123

Re: New registratiion rules to reduce bot registration

OK

I think I've managed to change the permissions so that new users have to post to the New Users section first

Next job is working out why we have 800 members who are fully registered but who never made a post.

I'll PM the most recent of these and see if they reply
by RogerClark
Sun Sep 24, 2017 11:03 pm
Forum: New users MUST post here first, and let us know a bit about you and your projects
Topic: Hello and help
Replies: 3
Views: 30

Re: Hello and help

Tom 10k is too high. Even on 5V systems the value is normally 4.7k. On 3.3V systems you should use around 2.7k Re: You code I amended your post to put the code in the code tags. Use the </> button, as it makes the code easier to read in the post. Also. You are still declaring and using HWire, There ...