Search found 1125 matches

Go to advanced search

by martinayotte
Sun Jan 22, 2017 8:46 pm
Forum: General discussion
Topic: printf and boot question
Replies: 11
Views: 175

Re: printf and boot question

@mamama1, good luck if you find better solution out in the jungle ... :ugeek:
by martinayotte
Sat Jan 21, 2017 3:23 pm
Forum: STM32F4 Boards
Topic: Compiling error STM32F407 SPI /ENC
Replies: 1
Views: 43

Re: Compiling error STM32F407 SPI /ENC

You need to include SPI.h before UIPEthernet.h and have global instance "SPIClass SPI(1)" in you main sketch.
by martinayotte
Thu Jan 19, 2017 12:25 am
Forum: Projects
Topic: $10 O-Scope revisited
Replies: 524
Views: 26733

Re: $10 O-Scope revisited

For that, you should find peaks high and low, and then calculate the delta in time, you will then be able to display frequency.
Maybe you will need to average that value and refresh display of that value only once in while in case it is drifting too much, otherwise, it will be difficult to read.
by martinayotte
Mon Jan 16, 2017 9:12 pm
Forum: STLink
Topic: Some pins not usable when using ST-Link ?
Replies: 33
Views: 1086

Re: Some pins not usable when using ST-Link ?

But the pill only has mounted SWD interface connector, which would only involve PA13/14, but not PB3/PB4 at all. Are you aware that SWD can be enabled while JTAG disabled ? typedef enum afio_debug_cfg { /** Full Serial Wire and JTAG debug */ AFIO_DEBUG_FULL_SWJ = AFIO_MAPR_SWJ_CFG_FULL_SWJ, /** Ful...
by martinayotte
Mon Jan 16, 2017 2:52 pm
Forum: STLink
Topic: Some pins not usable when using ST-Link ?
Replies: 33
Views: 1086

Re: Some pins not usable when using ST-Link ?

I think that daniel's idea is a good one :
maybe the disableDebug() should within the pinMode when those specific pins are specified.
by martinayotte
Sun Jan 15, 2017 8:44 pm
Forum: STLink
Topic: Some pins not usable when using ST-Link ?
Replies: 33
Views: 1086

Re: Some pins not usable when using ST-Link ?

You're right ! Roger did that change on December 26th, I don't know why other than allowing SWD debugging whatever upload method is used.

https://github.com/rogerclarkmelbourne/ ... a4b3925ffb
by martinayotte
Sun Jan 15, 2017 6:38 pm
Forum: STLink
Topic: Some pins not usable when using ST-Link ?
Replies: 33
Views: 1086

Re: Some pins not usable when using ST-Link ?

That is pretty normal to have this flag in the stlink upload method, since otherwise, you can only upload one time and then the SWD becomes disabled.
by martinayotte
Sun Jan 15, 2017 5:00 pm
Forum: STLink
Topic: Some pins not usable when using ST-Link ?
Replies: 33
Views: 1086

Re: Some pins not usable when using ST-Link ?

It is " #ifndef ", not " #ifdef ".
by martinayotte
Wed Jan 11, 2017 2:26 pm
Forum: Libraries & Hardware
Topic: Lib for ILI9486 - 3.5 inch 480x320 touch TFT for RPi
Replies: 125
Views: 1345

Re: Lib for ILI9486 - 3.5 inch 480x320 touch TFT for RPi

RogerClark wrote:What does the part of the circuit with 3 inverters in series do ?


The ring oscillator (3 invertors in loop) there did 150MHz freq.
by martinayotte
Mon Jan 09, 2017 1:11 am
Forum: General discussion
Topic: Guide for under- and over-clocking the blue-pill needed
Replies: 39
Views: 443

Re: Guide for under- and over-clocking the blue-pill needed

Then, you should do what Ray did a year go : switch to Linux and forget crappy MS Windows ... :lol:
I'm still running WinXP/WinVista/Win7 but inside VMs, so if you still need Windows for your consultant contracts, maybe that solution could fit your needs. ;)

Go to advanced search