Search found 208 matches

by rexnanet
Thu Dec 14, 2017 9:57 am
Forum: Projects
Topic: Open Energy Monitor
Replies: 65
Views: 9013

Re: Open Energy Monitor

Didn't remember that :) I was focused on using HW because of another project and didn't even remember I could use that on this one... Thanks :) How fast can it go (reliably)? Edit: answering myself: 38400 https://forum.arduino.cc/index.php?topic=431522.0 Probably other libraries could do more but th...
by rexnanet
Wed Dec 13, 2017 3:21 pm
Forum: Projects
Topic: DLO-138 OScope
Replies: 108
Views: 6994

Re: DLO-138 OScope

Now I have tested an quadencoder on an Namiki motor, the phase difference is 90° :lol: https://www.youtube.com/watch?v=GXj4ve7LpNQ&feature=youtu.be Nive work :) I've got some DSO150 to try them out. It works great but only one channel is not very nice :) I'm thinking about making a similar approach...
by rexnanet
Wed Dec 13, 2017 3:15 pm
Forum: Projects
Topic: Open Energy Monitor
Replies: 65
Views: 9013

Re: Open Energy Monitor

I'm going to try the ESP8266+MCP3008+emoncms.org approach first because it's simpler. Hi! Have you had a chance to progress with your idea? Hi PavloPub, I've actually went for an ESP8266+STM32F103 (blue pill) because of the already available code. But I found a problem, the UART pins on the ESP are...
by rexnanet
Sat Nov 11, 2017 8:35 am
Forum: Projects
Topic: DLO-138 OScope
Replies: 108
Views: 6994

Re: DLO-138 OScope

Nice work!
3.3V to 5V: why are you mentioning SPI? 3.3V SPI should work with 5V slave if you ignore MISO line.
MCP6022 doesn't have a great BW but should be enough.
Is your trigger done in SW? If so it should be easy.
by rexnanet
Wed Nov 01, 2017 5:49 pm
Forum: Projects
Topic: DLO-138 OScope
Replies: 108
Views: 6994

Re: DLO-138 OScope

Great work! :) Yes, that is probably the best approach. It was what I did with my setup. What is the amplitude of the input signal in the video? it seems to have a bit of noise... Are the amplitude measures working? They show values on the mV range... Is that the amplitude of the signal? If so that ...
by rexnanet
Sat Oct 07, 2017 6:24 pm
Forum: Projects
Topic: $10 O-Scope revisited
Replies: 683
Views: 106432

Re: $10 O-Scope revisited

I think that it might be kind of "2 separate channel interleaving". You might get ADC2 samples on the second 16 bits of every 32bit block. But channel 2 will not be sampled at the same time as channel 1. It will be offset by 7 ADC clocks. If setting ADC2 to pinB works, than the what I said before sh...
by rexnanet
Sat Oct 07, 2017 6:05 pm
Forum: Projects
Topic: DLO-138 OScope
Replies: 108
Views: 6994

Re: DLO-138 OScope

I'm not receiving e-mail notifications... Didn't notice that stuff was going on here :) Also a week of vacations meanwhile :) I've been able to get the basic wiring from your setup (@mausimick) (LCD and one encoder) and seems that it's working "OK". There are some glitches on D1 and D2, the selectio...
by rexnanet
Fri Sep 08, 2017 5:42 pm
Forum: Projects
Topic: DLO-138 OScope
Replies: 108
Views: 6994

Re: DLO-138 OScope

Ok, I'll take a look during this weekend. Today is a "no go" :)
by rexnanet
Fri Sep 08, 2017 9:47 am
Forum: Projects
Topic: DLO-138 OScope
Replies: 108
Views: 6994

Re: DLO-138 OScope

As a final resource, I can provide the libs I use that are from the early tests and "worked".
by rexnanet
Fri Sep 08, 2017 8:45 am
Forum: Projects
Topic: DLO-138 OScope
Replies: 108
Views: 6994

Re: DLO-138 OScope

Rexanet, now I have big problems - I think with the Adafruit_ILI9341_STM - lib. The SPI graphic functioned, but I can't activate other SPI devices like MCP6S91/92 or MCP4822 (DAC). I reduced the speed to 9MHz and back to 36MHz, but with no success. I tested it with "blue-Pill" and Maple-Mini - the ...