Search found 11 matches

by sgt_johnny
Thu Apr 06, 2017 4:25 pm
Forum: STM32F103 Boards
Topic: Anyway to "factory reset"?
Replies: 10
Views: 651

Re: Anyway to "factory reset"?

I just want to upload a sketch, but i guess the installed bootload does not match any "known" in the arduino software, since i never can upload. This is why i wanted to use the generic bootloader and then try again uploading
by sgt_johnny
Wed Apr 05, 2017 11:20 am
Forum: STM32F103 Boards
Topic: Anyway to "factory reset"?
Replies: 10
Views: 651

Re: Anyway to "factory reset"?

Im not comming to the selection of the bootloader with the "STM32 flash demonstrator",it cant make a connection.
by sgt_johnny
Tue Apr 04, 2017 5:40 pm
Forum: STM32F103 Boards
Topic: Anyway to "factory reset"?
Replies: 10
Views: 651

Re: Anyway to "factory reset"?

I tried to flash "generic_boot20_pb12.bin" from here http://wiki.stm32duino.com/index.php?title=Burning_the_bootloader, by that time, i did not knowing about the USB even working, i tried that out when nothing over serial worked. When i select maple mini in the boards, i'm getting this error wehn up...
by sgt_johnny
Tue Apr 04, 2017 3:14 pm
Forum: STM32F103 Boards
Topic: Anyway to "factory reset"?
Replies: 10
Views: 651

Anyway to "factory reset"?

Hello! I have bought a STM32F103 clone on ebay - it looks like this http://i.ebayimg.com/images/g/ZmsAAOSw-0xYZK3Z/s-l1600.jpg I tried to flash the bootloader with the "STM32 flash demonstrator" but always getting "incorrect device signature". If i try to check if the serial works (with hpyer termin...
by sgt_johnny
Mon Jan 23, 2017 6:31 pm
Forum: STM Nucleo boards
Topic: Nucleo F401 Arduino
Replies: 2
Views: 947

Nucleo F401 Arduino

Hello I'm having a Nucleo F401RE Board laying around here. Can i make it work with arduino? http://www.st.com/en/evaluation-tools/nucleo-f401re.html I tried to compile with the DiscoveryF407 and manually placed the .bin file in C:\Users\User\AppData\Local\Temp\arduino_build_570452 into the Volume, t...
by sgt_johnny
Thu Jan 19, 2017 7:03 pm
Forum: STM32F103 Boards
Topic: STM32F103CB Dual SPI
Replies: 10
Views: 1077

Re: STM32F103CB Dual SPI

Sorry, i might be have not provided enough info The manufacturer of the DOG128 provided a working library for the arduino boards. See library attached The code sniped i attached is from that library. My question is, if this would work with the second SPI port of the STM32. I have read about the SD-C...
by sgt_johnny
Thu Jan 19, 2017 6:03 pm
Forum: STM32F103 Boards
Topic: STM32F103CB Dual SPI
Replies: 10
Views: 1077

Re: STM32F103CB Dual SPI

How can i find out if the used library works with a SPI2 object? Here is my application: This is the code in the .ino file of a example program written for arduino uno. DOG.initialize(10,0,0,9,4,DOGM128); //SS = 10, 0,0= use Hardware SPI, 9 = A0, 4 = RESET, EA DOGM128-6 (=128x64 dots) in the corresp...
by sgt_johnny
Wed Jan 18, 2017 1:01 pm
Forum: STM32F103 Boards
Topic: STM32F103CB Dual SPI
Replies: 10
Views: 1077

Re: STM32F103CB Dual SPI

Is there any tutorial/exmaple how i tell the SPI library that there is a second port, and which one sould be used?
by sgt_johnny
Wed Jan 18, 2017 12:22 pm
Forum: STM32F103 Boards
Topic: STM32F103CB Dual SPI
Replies: 10
Views: 1077

STM32F103CB Dual SPI

Hello Im currently working on a prototype ATMEGA328 project and i'm a.) running out of pins b.) worry about SPI I have do communicate with two SPI-Devices (SD-Card Mode 0) and (Display Mode 3). So to communicate i need to completly shut down communciation, change spi mode, and then restart with diff...
by sgt_johnny
Mon Jun 20, 2016 12:58 pm
Forum: Projects
Topic: STM32 Arduino on own Board
Replies: 7
Views: 928

Re: STM32 Arduino on own Board

Thanks for your answer.

LQFP is not that much of a problem, i soldered a few of them.

Thanks for the advice, i will get a maple mini board for testing.