Search found 237 matches

by Nutsy
Mon Jul 31, 2017 2:40 pm
Forum: Libraries & Hardware
Topic: best way to construct dynamic strings/char arrays?
Replies: 8
Views: 217

Re: best way to construct dynamic strings/char arrays?

did find this method which is a bit long winded... char tmpSign = (foo < 0) ? "-" : ""; float tmpVal = (foo < 0) ? -foo : foo; int tmpInt1 = tmpVal; // Get the integer (678). float tmpFrac = tmpVal - tmpInt1; // Get fraction (0.0123). int tmpInt2 = trunc(tmpFrac * 100); // Turn into integer (123). s...
by Nutsy
Mon Jul 31, 2017 12:12 pm
Forum: Libraries & Hardware
Topic: best way to construct dynamic strings/char arrays?
Replies: 8
Views: 217

Re: best way to construct dynamic strings/char arrays?

Yeah i realise that memory limits is the real reason why strings arent widely supported. And yes %f doesnt work with sprintf, just get a ? as a result . I was also told I should use snprintf rather than sprintf, not sure of the reasons why. So building into allocated char arrays is the done thing? :...
by Nutsy
Sun Jul 30, 2017 1:50 pm
Forum: Libraries & Hardware
Topic: best way to construct dynamic strings/char arrays?
Replies: 8
Views: 217

best way to construct dynamic strings/char arrays?

In maple whats the best way to construct dynamic strings and char arrays? As you know im upgrading my speedo graphics to EVE. And i need to build some dynamic strings to show things like worded dates " Wed 15th july 2017" for instance. I need to be able to convert floats and doubles to strings and w...
by Nutsy
Thu Jul 27, 2017 10:01 am
Forum: IDE's
Topic: Getting Eclipse to work? A proper guide?
Replies: 12
Views: 343

Re: Getting Eclipse to work? A proper guide?

lol ahhh :D yeah later version would be f4 but still on the f1 at the moment
by Nutsy
Wed Jul 26, 2017 4:53 pm
Forum: IDE's
Topic: Getting Eclipse to work? A proper guide?
Replies: 12
Views: 343

Re: Getting Eclipse to work? A proper guide?

I must admit I couldnt find that line in the platform.txt file...

Another bug ive always had as well is even though Im on a mac eclipse kept trying to trigger the windows tools...

i just gave the mac url into the windows flags in the config
by Nutsy
Wed Jul 26, 2017 9:42 am
Forum: IDE's
Topic: Getting Eclipse to work? A proper guide?
Replies: 12
Views: 343

Re: Getting Eclipse to work? A proper guide?

well back on Neon3 as of yesterday and its till not perfect but i can at least code again... I still have the issue with custom function calls throwing faulse errors about the call... But i do a index rebuild and it works again for a while... If i ass several more functions or details it looses it a...
by Nutsy
Tue Jul 25, 2017 10:35 am
Forum: IDE's
Topic: Getting Eclipse to work? A proper guide?
Replies: 12
Views: 343

Re: Getting Eclipse to work? A proper guide?

ahh so it is the oxygen version thats causing the faults...
It really has been causing so much headache for me...
by Nutsy
Mon Jul 24, 2017 5:41 pm
Forum: IDE's
Topic: Getting Eclipse to work? A proper guide?
Replies: 12
Views: 343

Getting Eclipse to work? A proper guide?

Right im pulling my hair out trying to get Eclipse to work... Ive followed the guide in the wiki and that no longer works... My trouble when i upgraded from neon to oxygen... I get all sorts of strange random errors from boards not loading to core folders not listing everything in the core. heck eve...
by Nutsy
Wed Jul 19, 2017 12:00 pm
Forum: IDE's
Topic: PlatformIO- How to get it to use Rogers core?
Replies: 1
Views: 133

PlatformIO- How to get it to use Rogers core?

Well im giving up on eclipse again. i simply cant get it to behave any more. So going back to platformIO they have updated their system to v2beta something........ Does anyone happen to know how to get it to link correctly to the downloaded stm32duino core inside the arduino/hardware folder, rather ...
by Nutsy
Mon Jul 17, 2017 4:21 pm
Forum: IDE's
Topic: IDE with Eclipse with Jantje's plugin
Replies: 136
Views: 6173

Re: IDE with Eclipse with Jantje's plugin

I made a mistake of updating eclipse and noe everythings broken. Even Sloeber on its own version of eclipse. I have no code autocomplete. Ive managed to make the libraries appear to reconnect so stupid false syntax errors have stopped. But as i said No code autocomplete. And it wont compile either. ...