Search found 179 matches

by fpiSTM
Sun Sep 24, 2017 1:38 pm
Forum: STM core: Bugs and enhancements
Topic: tone() not working on F072-Discovery
Replies: 9
Views: 66

Re: tone() not working on F072-Discovery

Thanks ekawahyu

One question about your repo, why adding some CMSIS header file?
https://github.com/ekawahyu/Arduino_Cor ... 3d342b8730
They are already available in the CMSIS 4.5.0 arduino package?
This is for the opeOCD and Makefile need?
by fpiSTM
Sun Sep 24, 2017 7:22 am
Forum: Builds and Announcements
Topic: Unverified user deletion
Replies: 5
Views: 94

Re: Unverified user deletion

Thanks for your work Roger.
by fpiSTM
Sat Sep 23, 2017 7:27 pm
Forum: STM core: Bugs and enhancements
Topic: tone() not working on F072-Discovery
Replies: 9
Views: 66

Re: tone() not working on F072-Discovery

Ok I will do some tests on monday.
Could you submit an issue on the Arduino_Core_STM32 to track this issue and add the link to this post. please?
by fpiSTM
Sat Sep 23, 2017 9:56 am
Forum: STM core: Bugs and enhancements
Topic: tone() not working on F072-Discovery
Replies: 9
Views: 66

Re: tone() not working on F072-Discovery

Your variant seems ok. nice job. After checking the STM32F072 specification: http://www.st.com/content/ccc/resource/technical/document/datasheet/cd/46/43/83/22/d3/40/c8/DM00090510.pdf/files/DM00090510.pdf/jcr:content/translations/en.DM00090510.pdf TIM14 This timer is based on a 16-bit auto-reload up...
by fpiSTM
Sat Sep 23, 2017 7:21 am
Forum: STM core: Bugs and enhancements
Topic: tone() not working on F072-Discovery
Replies: 9
Views: 66

Re: tone() not working on F072-Discovery

Ok. I will have a look.
by fpiSTM
Sat Sep 23, 2017 7:20 am
Forum: STM32generic
Topic: B-L475E-IOT01A
Replies: 9
Views: 117

Re: B-L475E-IOT01A

You could have a look here to compare sequence https://github.com/stm32duino/Arduino_Core_STM32/blob/f50f7bdfaf7a15f606e64b8d37b5c3e2993c5749/cores/arduino/stm32/analog.c#L554 Fyi, the L4 disco iot is now supported by the Arduino_Core_STM32. Moreover several libs have been released to support sensor...
by fpiSTM
Sat Sep 23, 2017 7:07 am
Forum: STM core: Bugs and enhancements
Topic: [SOLVED] ST-Link bug?
Replies: 5
Views: 96

Re: [SOLVED]ST-Link bug?

Welcome ;)
by fpiSTM
Fri Sep 22, 2017 7:37 am
Forum: STM core: Bugs and enhancements
Topic: [SOLVED] ST-Link bug?
Replies: 5
Views: 96

Re: ST-Link bug?

Ok thanks. So, two possibilities: 1- old firmware, please upgrade it thanks the ST-LINK/V2-1 firmware upgrade available here: https://my.st.com/content/my_st_com/en/products/development-tools/software-development-tools/stm32-software-development-tools/stm32-programmers/stsw-link007.license%3d1506006...
by fpiSTM
Fri Sep 22, 2017 5:30 am
Forum: PR's bugs and enhancements
Topic: PR to add optimisation menu (to all boards individually)
Replies: 27
Views: 495

Re: PR to add optimisation menu (to all boards individually)

Yes in fact it's a regression of the v6. so v4.8 is not impacted.
by fpiSTM
Thu Sep 21, 2017 8:29 pm
Forum: STM core: Bugs and enhancements
Topic: [SOLVED] ST-Link bug?
Replies: 5
Views: 96

Re: ST-Link bug?

Hi, on which OS you run Arduino?