RFM69

Can someone help me port this library?
stevestrong
Posts: 1604
Joined: Mon Oct 19, 2015 12:06 am
Location: Munich, Germany

Re: RFM69

Post by stevestrong » Sun Feb 19, 2017 11:55 am

My issue was not related to SPI.
The reception part did not work as expected, but now seems to work ok.

zmemw16
Posts: 1414
Joined: Wed Jul 08, 2015 2:09 pm
Location: St Annes, Lancs,UK

Re: RFM69

Post by zmemw16 » Sun Feb 19, 2017 6:14 pm

apols
the difference in the snippets was spi1 cf spi2, but they used the same divider.
clk into divider for spi1 and spi2 is?
stephen

stevestrong
Posts: 1604
Joined: Mon Oct 19, 2015 12:06 am
Location: Munich, Germany

Re: RFM69

Post by stevestrong » Sun Feb 19, 2017 6:32 pm

I am mostly using beginTransaction mit settings:

Code: Select all

	// Start up
	SPI.setModule(1); // nRF905
	SPI.beginTransaction(SPISettings(9000000));
	nRF905_Init();
	Serial.println(F("-> nRF905 initialised."));

	Serial.print("Initialise RFM69...");
	SPI.setModule(2); // RFM69
	SPI.beginTransaction(SPISettings(9000000));
	if ( !rfm69.begin(RFM69_CS, RFM69_RST) ) {
	...
	}
This way I don't care about choosing the right divider.

zmemw16
Posts: 1414
Joined: Wed Jul 08, 2015 2:09 pm
Location: St Annes, Lancs,UK

Re: RFM69

Post by zmemw16 » Sun Feb 19, 2017 9:13 pm

well worth a mention :)

kylix
Posts: 4
Joined: Mon Jul 10, 2017 6:30 pm

Re: RFM69

Post by kylix » Sun Jul 16, 2017 8:13 am

I'm having problems too on a STM32L053R8 board. The sketch compiles OK and runs on the board but the gateway doesn't receive any message.
I can read the registries and the temperature from the RFM69HW module.

stevestrong
Posts: 1604
Joined: Mon Oct 19, 2015 12:06 am
Location: Munich, Germany

Re: RFM69

Post by stevestrong » Sun Jul 16, 2017 8:23 am

With a RTL SDR you could test whether the TX part is really working.

kylix
Posts: 4
Joined: Mon Jul 10, 2017 6:30 pm

Re: RFM69

Post by kylix » Sun Jul 16, 2017 10:15 am

I'm not sure about the IRQ settings. The library I'm trying to use is this: https://github.com/brainelectronics/RFM69-STM32

PS: I've just checked with SDRSharp software and ... nothing goes out from the TX. (I have other 433Mhz nodes and I can clearly see when they transmit).

Post Reply