Radio library Bluepill

Can someone help me port this library?
User avatar
RogerClark
Posts: 7690
Joined: Mon Apr 27, 2015 10:36 am
Location: Melbourne, Australia
Contact:

Re: Radio library Bluepill

Post by RogerClark » Sun Jul 23, 2017 12:03 am

Have you confirmed that the stations you receive eg. at 100Mhz actually transmit at 100Mhz

i.e Its possible that the frequency calculation you are using is incorrect and that when you try to receive on 103 you are telling it to receive on 108 or higher.

Sounds more like your board just doesnt receive very well above 103.5

Do you have another receiver to compare it with.
Did you try a different antenna etc

iscle
Posts: 7
Joined: Thu Apr 27, 2017 11:06 am
Location: Barcelona

Re: Radio library Bluepill

Post by iscle » Sun Jul 23, 2017 12:18 am

RogerClark wrote:
Sun Jul 23, 2017 12:03 am
Have you confirmed that the stations you receive eg. at 100Mhz actually transmit at 100Mhz

i.e Its possible that the frequency calculation you are using is incorrect and that when you try to receive on 103 you are telling it to receive on 108 or higher.

Sounds more like your board just doesnt receive very well above 103.5

Do you have another receiver to compare it with.
Did you try a different antenna etc
Yes, all the stations under 103.50MHz are the correct ones, I've used another radio to confirm that they really were the ones supposed to be. That's how I found that the "maximum" station that it would receive.
Even if reboot the radio and tell it to sync, for example, 100.0MHz it will do it, but then if you directly sync 104.2 or even 106.1 the 103.5MHz station will start being received with a lot of noise. I can make a video if it helps.

Thanks.

Post Reply