Repo updated with various PRs

Information on the latest releases
Post Reply
User avatar
RogerClark
Posts: 6909
Joined: Mon Apr 27, 2015 10:36 am
Location: Melbourne, Australia
Contact:

Repo updated with various PRs

Post by RogerClark » Sun Oct 16, 2016 10:59 pm

Guys

I've pulled 3 new PRs into the repo, these relate to ADC DMA (and callbacks), SPI and also to USB Serial

I'm never able to completely test everything, but I did some basic tests of USB and SPI and ADC and as far as I can tell the repo is still functioning OK.
But I would view it as possibly containing bugs until a few more people have had chance to download it and use it for these current projects.

Phisatho
Posts: 16
Joined: Fri Oct 28, 2016 1:24 pm

Re: Repo updated with various PRs

Post by Phisatho » Fri Oct 28, 2016 2:38 pm

Can I simply zip download from Git-Hub and unpack over the previous installation?

stevestrong
Posts: 1608
Joined: Mon Oct 19, 2015 12:06 am
Location: Munich, Germany

Re: Repo updated with various PRs

Post by stevestrong » Fri Oct 28, 2016 3:31 pm

Phisatho wrote:Can I simply zip download from Git-Hub and unpack over the previous installation?
Yes, this is an alternative way to use the latest version from repo.

stevestrong
Posts: 1608
Joined: Mon Oct 19, 2015 12:06 am
Location: Munich, Germany

Re: Repo updated with various PRs

Post by stevestrong » Mon Oct 31, 2016 9:40 pm

Roger, it seems that a fle is missing from one of the last commits.
In Print.h there is the line

Code: Select all

+#include "Printable.h"
but that is missing. I get an error when trying to compile.

User avatar
RogerClark
Posts: 6909
Joined: Mon Apr 27, 2015 10:36 am
Location: Melbourne, Australia
Contact:

Re: Repo updated with various PRs

Post by RogerClark » Mon Oct 31, 2016 10:42 pm

Looks like a screw up in one of the PR's

I merged one which I thought was just for the F4, but perhaps it also had F1 files

stevestrong
Posts: 1608
Joined: Mon Oct 19, 2015 12:06 am
Location: Munich, Germany

Re: Repo updated with various PRs

Post by stevestrong » Wed Nov 02, 2016 9:43 am

I figured it out my local repo was somehow not complete, in the cloud repo the file is there.
But with this latest Stream class I have hang ups now. I reverted locally and the problem is gone. So it seems something is wrong there.
I'll do some more tests.

Post Reply