Bootloader updated to support newer versions of GCC

Information on the latest releases
User avatar
RogerClark
Posts: 5595
Joined: Mon Apr 27, 2015 10:36 am
Location: Melbourne, Australia
Contact:

Bootloader updated to support newer versions of GCC

Postby RogerClark » Thu Nov 10, 2016 12:53 am

I've updated the bootloader with a fix from Philippe LUC (@philfifi on github), for the problem with newer versions of GCC (4.9 or newer)

I've tested it with gcc and built new versions of the BackPill and also for the GD32 and both seem to work when I compiled using gcc 5.4

So all the binaries have also now been updated with the version using gcc 5.4 and the fix by Philippe (and I applied the fix to the GD32 bootloader)

Philippe has tested with GCC 6, but I've not personally done this, as I only have 5.4 installed (as well as 4.9 and 4.8)

Return to “Builds and Announcements”

Who is online

Users browsing this forum: No registered users and 1 guest