Bring in the ChibiOS HAL?

What could be included in further releases, or for the forum.
jcw
Posts: 170
Joined: Mon Oct 26, 2015 8:16 am

Re: Bring in the ChibiOS HAL?

Postby jcw » Fri Oct 30, 2015 6:45 pm

Did someone say Eclipse? Fresh article on HAD:

http://hackaday.com/2015/10/30/code-cra ... velopment/

User avatar
RogerClark
Posts: 5465
Joined: Mon Apr 27, 2015 10:36 am
Location: Melbourne, Australia
Contact:

Re: Bring in the ChibiOS HAL?

Postby RogerClark » Fri Oct 30, 2015 10:44 pm

Thanks

I noticed that as well, but have not read it yet.

I know a few people on the forum have managed to configure Eclipse for use with Arduino and the STM32 but I"ve not had much luck when I tried (and I don't have a huge amount of spare time to spend on it :-(

Edit.
It looks like the article focuses on Linux. I think @rickkimball has it set up and working, but I suspect the on Windows that things are still not that straightforward

zmemw16
Posts: 975
Joined: Wed Jul 08, 2015 2:09 pm
Location: St Annes, Lancs,UK

Re: Bring in the ChibiOS HAL?

Postby zmemw16 » Sat Oct 31, 2015 12:53 am

eclipsearduino
i've just tried it again on this debian 8 system, it complains about 1.6.5r? and shows 1.6.4 for software;
i can see a selection list of boards.txt
my main arduino 1.6.5 is installed in ~/ard165 and the 'boards.txt's listed are from the hardware directory in that location.
it doesn't see the ~/sketchbook/hardware/Arduino_STM32 directory, this i believe is the recommended way for us(?)
i did configure the plugin with the correct paths for my sketchbook, libraries and hardware. i use a soft link for ~/sketchbook to 'sketchbook_STM32 and in sketchbook/hardware' is another soft link to the 'current' Arduino_STM32' directory.

i'll go off and have a play with directories under ~/ard165xx ...

edit1
the directories listed are from ~/.arduino15 and ard165xxx/hardware, not seeing sketchbook/hardware
edit2
moved stm32 to ard165xxx/hardware, now seeing stm32 boards / variant/ upload options
tried a compile and got ......
copied gcc-arm....etc into hardware/tools/gcc....
now moans about missing "libmaple/libmaple_types.h"
include path screwed up i suspect

i'm reverting.

stephen


Return to “Ideas & suggestions”

Who is online

Users browsing this forum: No registered users and 1 guest