Warning: platform.txt from core...

Windows XP,Vista,7,8 and 8.1 etc
Post Reply
User avatar
Kurt_R
Posts: 15
Joined: Thu Nov 05, 2015 1:13 am

Warning: platform.txt from core...

Post by Kurt_R » Sat Nov 07, 2015 4:32 am

Just trying out some things and installed a fresh copy of Windows 8, the Arduino IDE 1.6.6 and STM32.
After installing the SAM boards [1.6.6 which was just released today] and
then the STM32 files I get a bunch of the attached errors for various boards cover by this install.

They mention deprecated recipes and compiler paths, among other things, but it's all Greek to me.

Any help would be appreciated.

Kurt
Attachments
Document.txt
(5.12 KiB) Downloaded 58 times

jcw
Posts: 171
Joined: Mon Oct 26, 2015 8:16 am

Re: Warning: platform.txt from core...

Post by jcw » Sat Nov 07, 2015 10:29 am

See this post: http://www.stm32duino.com/viewtopic.php ... 711&p=7823
Better switch back to 1.6.5 for now...

-jcw

User avatar
RogerClark
Posts: 7555
Joined: Mon Apr 27, 2015 10:36 am
Location: Melbourne, Australia
Contact:

Re: Warning: platform.txt from core...

Post by RogerClark » Sat Nov 07, 2015 8:11 pm

The deprecated recipies dont stop it working, its the libraries that are crashing it.

I took a quick look at our build recipies vs the due recipies, but could not see any obvious errors

i.e they dont seem to have changed the names of the recipies.
It looked like the IDE had an issue when processing the substitutions possibly.

I will download the zip version and create a Portable / separate version to see if I can figure out what it doesnt like with the recipies.

IMHO, The main problem is that the IDE team view the whole thing as a commercial product just to support sales of their boards.

Although they added third party support in IDE 1.5.8, they could not be bothered even to finish the documentation on how to add third part boards.
They did some docs but AFIK its never been finished

They dont seem to notify the developers mailing list when they make big changes, and generally dont seem interested in supporting third party boards.

I offered to send them some Maple mini boards, but their declined my offer. They said they could buy their own, but I dont think they ever did :-(

User avatar
Kurt_R
Posts: 15
Joined: Thu Nov 05, 2015 1:13 am

Re: Warning: platform.txt from core...

Post by Kurt_R » Sun Nov 08, 2015 12:06 am

Okay, I will revert to 1.6.5 then.
I haven't needed to use anything from the new core anyway, so I'll be alright.

User avatar
RogerClark
Posts: 7555
Joined: Mon Apr 27, 2015 10:36 am
Location: Melbourne, Australia
Contact:

Re: Warning: platform.txt from core...

Post by RogerClark » Sun Nov 08, 2015 12:58 am

I've done some fixes to the master branch of the repo, but 1.6.6 looks like quite a mess.

I can't seem to have 1.6.5 and 1.6.6 co-resident even if I have 1.6.6 in a portable folder.

I will need to install 1.6.6 on a completely different machine so it doesnt stuff up my main machine.

I suspect that the IDE team will need to release an update fairly soon to correct the various things they have broken.

rajdarge
Posts: 56
Joined: Thu Oct 29, 2015 10:27 am

Re: Warning: platform.txt from core...

Post by rajdarge » Thu Nov 12, 2015 12:42 pm

I also had this problem, the wire library was very broken.

In rolling back , you have to rollback the arduino uno board to 1.5.8 as well as apparently v1.5.9 (part of 1.6.6 arduino) is not compatible or something....
https://forum.arduino.cc/index.php?topic=359049.0

User avatar
RogerClark
Posts: 7555
Joined: Mon Apr 27, 2015 10:36 am
Location: Melbourne, Australia
Contact:

Re: Warning: platform.txt from core...

Post by RogerClark » Thu Nov 12, 2015 9:31 pm

The platform.txt stuff is caused because the IDE made a change which makes it impossible to have both 1.6.5 and 1.6.6 on the same machine ( well there is the hack that the EPS8266 guys are using but that hack kills the compiled files cache, so I'm not going to use it)

There are still loads of reports of other problems on Linux etc.

Post Reply