Can't initiate chip erase

Windows XP,Vista,7,8 and 8.1 etc
User avatar
RogerClark
Posts: 7171
Joined: Mon Apr 27, 2015 10:36 am
Location: Melbourne, Australia
Contact:

Re: Can't initiate chip erase

Post by RogerClark » Fri Nov 20, 2015 8:34 pm

thebeline wrote:Could you direct me to how to flash the bootloader? I have your Git Repo. I can see how to use some of the utilities via CMD, but this is my first time with anything non-Arduino (strict).
the boot loader is in a separate repo on my account.

Look in the stm32duino-bootloader repo, in the binaries folder, pick the bin file that matches you board ( I think it's generic pc13)

Download the bin ( note on GitHub you need to go into the file and press the Raw button), download...

Then flash using STMs tool

willbird
Posts: 1
Joined: Wed Feb 03, 2016 11:48 pm

Re: Can't initiate chip erase

Post by willbird » Wed Feb 03, 2016 11:57 pm

I just got my first Blue Pill the other day. Was having trouble getting anything to upload using Arduino IDE and serial.

Found this thread and went looking for a flash uploader for Linux.
Ended up using stm32flash and this command.

Code: Select all

sudo stm32flash -k  /dev/ttyUSB0
And got this result

Code: Select all

stm32flash 0.4
http://stm32flash.googlecode.com/

Interface serial_posix: 57600 8E1
Version      : 0x22
Option 1     : 0x00
Option 2     : 0x00
Device ID    : 0x0410 (Medium-density)
- RAM        : 20KiB  (512b reserved by bootloader)
- Flash      : 128KiB (sector size: 4x1024)
- Option RAM : 16b
- System RAM : 2KiB
Read-UnProtecting flash
Done.
Removing WRITE protect did not seem to do anything for me but the read protect did.

Post Reply