Help starting out

Apple Mac OSX
Post Reply
Ragnarok
Posts: 13
Joined: Mon Aug 29, 2016 1:04 pm

Help starting out

Post by Ragnarok » Tue Sep 06, 2016 2:47 pm

Hello all!
I recently posted a thread asking for help with an error I faced (still not resolved!). After long hours (every day, for a week!) of searching the internet, I still haven't got answers .
I realized that I probably shouldn't blindly follow Youtube tutorials on this issue, but try to understand what I'm doing and why. (PS: I'm decent at C/C++, and terminal commands)

Do you guys have any suggestions on how I should start? How I can get my STM32 board to work? How I can figure out why it's finally working (if it ever does)?

Here's what I need to do: Program my STM with the help of FTDI and Arduino IDE. I would also love to have explanations on how to install the STM drivers required and why (if possible).
Gear:
STM32F103C mini development board - http://www.ebay.in/itm/STM32F103C8T6-AR ... Sw9NdXtDGO
FTDI RS232
OS X El Capitan.

User avatar
RogerClark
Posts: 7485
Joined: Mon Apr 27, 2015 10:36 am
Location: Melbourne, Australia
Contact:

Re: Help starting out

Post by RogerClark » Tue Sep 06, 2016 9:26 pm

Did you read the FAQ in the Welcome section ?

Ragnarok
Posts: 13
Joined: Mon Aug 29, 2016 1:04 pm

Re: Help starting out

Post by Ragnarok » Wed Sep 07, 2016 12:21 pm

Hey Roger!
Yes, I just did. I've got the basic idea down, but even though I follow the procedures given, I still can't get my board to work. :(

User avatar
Kenjutsu
Posts: 134
Joined: Fri May 29, 2015 8:26 am

Re: Help starting out

Post by Kenjutsu » Thu Nov 03, 2016 4:17 pm

Can you give more details specifically on what errors, if any, you are getting?
Pieter

OSX: 10.12.6
Arduino IDE: 1.6.12
Blue pill STM32F103C8T6 Dev Board
Maple Mini Clones

Post Reply