Getting started with Maple Mini on OS X 10.10 + Arduino 1.6.5

Apple Mac OSX
User avatar
RogerClark
Posts: 7482
Joined: Mon Apr 27, 2015 10:36 am
Location: Melbourne, Australia
Contact:

Re: Getting started with Maple Mini on OS X 10.10 + Arduino 1.6.5

Post by RogerClark » Tue Apr 26, 2016 11:03 pm

Install IDE 1.6.5 from the main Arduino site under the "Old versions" section.

There is documentation on how to install the "core"

https://github.com/rogerclarkmelbourne/ ... stallation

On OSX some users also need to install dfu-util using homebrew http://brew.sh/

DJ Namaste
Posts: 5
Joined: Wed Apr 20, 2016 4:26 pm

Re: Getting started with Maple Mini on OS X 10.10 + Arduino 1.6.5

Post by DJ Namaste » Wed Apr 27, 2016 5:57 pm

Using osx yosemite 10.10.5 I am getting this error

/Applications/Arduino 2 - AUG 2015.app/Contents/Java/hardware/Arduino_STM32/tools/macosx/maple_upload: line 34: /Applications/Arduino: No such file or directory

Any clues?

User avatar
martinayotte
Posts: 1229
Joined: Mon Apr 27, 2015 1:45 pm

Re: Getting started with Maple Mini on OS X 10.10 + Arduino 1.6.5

Post by martinayotte » Wed Apr 27, 2016 8:03 pm

Is the above path for maple_upload file is correct ?
Maybe IDE has issue with the spaces found in the path, if so, you can maybe workaround it by creating symbolic link, or simply move the folder in better location.

DJ Namaste
Posts: 5
Joined: Wed Apr 20, 2016 4:26 pm

Re: Getting started with Maple Mini on OS X 10.10 + Arduino 1.6.5

Post by DJ Namaste » Wed Apr 27, 2016 9:15 pm

Figured out what the last problem was. Arduino had been renamed.

This is my last error and it advises a update for osx but im already running 10.10.5

dyld: Library not loaded: /opt/local/lib/libusb-1.0.0.dylib
Referenced from: /Applications/Arduino.app/Contents/Java/hardware/Arduino_STM32/tools/macosx/dfu-util/dfu-util
Reason: image not found
/Applications/Arduino.app/Contents/Java/hardware/Arduino_STM32/tools/macosx/maple_upload: line 53: 1396 Trace/BPT trap: 5 ${DFU_UTIL} -d ${usbID} -a ${altID} -D ${binfile} -R ${dfuse_addr} -R

Oli
Posts: 9
Joined: Wed Apr 27, 2016 12:26 am

Re: Getting started with Maple Mini on OS X 10.10 + Arduino 1.6.5

Post by Oli » Wed Apr 27, 2016 10:43 pm

Did you try to install dfu-util with home-brew as described here: http://www.stm32duino.com/viewtopic.php ... t=10#p4926
That helped me in a similar case.

Post Reply