Page 1 of 1

What version of Arduino to install @ Mar-2017

Posted: Thu Mar 16, 2017 6:28 pm
by Bingo600
Hello Board

I'm using Linux Mint 17.3 (X64) , and currently have Arduino 1.6.13 installed.

I have been searching a bit around and found ref's to 1.6.12 and even 1.6.9
https://github.com/rogerclarkmelbourne/ ... stallation

And even some "official support"
viewtopic.php?f=16&t=1766

What should i do/use/install ?

Follow the install from the "Wikki" w. 1.6.9 , reuse my 1.6.13 ?
Do you guyzz use the git repos or the static zipfile ?

Use something else ??

Ohh i wouldn't mind to keep 6.1.13 if possible , as i use it for expressif also

Edit:

I ended up using arduino 1.6.13 w. the arduino (Cortex M0+ / Zero package)
To install stm32duino support i just did a :
cd arduino/hardware
git clone https://github.com/rogerclarkmelbourne/ ... _STM32.git

Restarted arduino , and i was ready.

The blue pill has the led on C13 , i made a short blinky attached

/Bingo

Re: What version of Arduino to install @ Mar-2017

Posted: Thu Mar 16, 2017 9:01 pm
by RogerClark
I think It should work with 1.6.13

I am currently running 1.8.0, and I have been told 1.8.1 also works.

( on the whole, most if the recent versions work Ok. There was a bad path around 1.6.8 (I think) where the Arduino team changed some stuff and made it incompatible with lots of Third Party Cores! but nothing they have changed recently has been a problem.

Re: What version of Arduino to install @ Mar-2017

Posted: Thu Mar 16, 2017 9:21 pm
by Bingo600
RogerClark wrote:I think It should work with 1.6.13

I am currently running 1.8.0, and I have been told 1.8.1 also works.

( on the whole, most if the recent versions work Ok. There was a bad path around 1.6.8 (I think) where the Arduino team changed some stuff and made it incompatible with lots of Third Party Cores! but nothing they have changed recently has been a problem.


Thanx Roger

Should i use your github , from the install url ?

Rgds
Bingo

Re: What version of Arduino to install @ Mar-2017

Posted: Fri Mar 17, 2017 2:27 am
by RogerClark
Manual install from github will get you the latest version.

There is a URL install, but its not produced by me, so I'm not sure how up to date it is.

Re: What version of Arduino to install @ Mar-2017

Posted: Fri Mar 17, 2017 8:38 pm
by Bingo600
I just prepared 12 x STM32 bluepill , replacing R10 (10K) with 1K5 0603's.

Actually my first real 0603 job, and it took less than 1 hr :D

I made a makefile for programming the bootloader via OOCD & a cheap STLink-v2 (Clone)

Expect the bootloader to be symlinked to the file boot.bin

Usage : make program

STLink-V2 connections : SWCLK , SWDIO , GND , RESET

stm32f103c8t6_pinout.jpg
stm32f103c8t6_pinout.jpg (208.6 KiB) Viewed 478 times



Hope it's usefull for someone


Later on i used these settings from the Arduino IDE , to upload new sketches.

Menu_016.png
Menu_016.png (15.32 KiB) Viewed 476 times



/Bingo

Re: What version of Arduino to install @ Mar-2017

Posted: Fri Mar 17, 2017 9:37 pm
by Bingo600
Ohh initially i had some upload probs , after installing the Bootloader.

I think it could be the : =# !)!%("!("# BLODY - Modem Manager again
It grabs the serial if at enumeration , and throws AT commands at it , in order to see if it's a modem.

That locks the serial for some time , and sends garbage to your device :evil: :evil:

Attached is my modified blacklist script from udev

/Bingo