Page 1 of 1

I killed my Maple Mini

Posted: Mon Apr 10, 2017 4:54 pm
by asen0v
Hi, today I killed my Maple Mini. It does not switch on when powered from 3.3V input pin. It powers on when powered from the USB or from VIN pin, but the microcontroller is getting hot after 2-3 seconds. Any ideas how to bring it back to life :) ?

Re: I killed my Maple Mini

Posted: Mon Apr 10, 2017 7:30 pm
by stevestrong
Throw some cold ice on it :mrgreen:

How did you manage?

Re: I killed my Maple Mini

Posted: Mon Apr 10, 2017 8:14 pm
by asen0v
Throw some cold ice on it :mrgreen:
I may try with some nitrogen :D
I did not even understand how I managed to do this. It was connected to a board with several buttons and I was soldering some diodes to this board. Later when I switched on the power, the maple mini was not working anymore :)
I changed the ams1117 and the diode next to it, but this did not help. I threw it in the bin and opened a new one. Hope to get more luck with this one :)

Re: I killed my Maple Mini

Posted: Mon Apr 10, 2017 9:45 pm
by stevestrong
Was it really a maple mini or rather a blue pill?
I thought mm are better (more resistant) then the bp.
I never lost any bp so far.

Re: I killed my Maple Mini

Posted: Mon Apr 10, 2017 9:54 pm
by ahull
asen0v wrote:
Throw some cold ice on it :mrgreen:
I may try with some nitrogen :D
I did not even understand how I managed to do this. It was connected to a board with several buttons and I was soldering some diodes to this board. Later when I switched on the power, the maple mini was not working anymore :)
I changed the ams1117 and the diode next to it, but this did not help. I threw it in the bin and opened a new one. Hope to get more luck with this one :)
Soldering with it disconnected from any power source I hope. My best guess is a solder splash... look for some tiny tinny balls on the PCB with a magnifier. :idea:
Sounds like you've earned a magic smoke badge. :D Welcome to the club.. -> viewtopic.php?f=3&t=22&hilit=let+out+the+magic+smoke

Image

Re: I killed my Maple Mini

Posted: Tue Apr 11, 2017 1:12 pm
by asen0v
ahull, at least now I know I am not alone :)))
stevestrong, it was MM from baite. I only buy from baite. I like their maple minies and also their one-sided arduino nanos.

Re: I killed my Maple Mini

Posted: Tue Apr 18, 2017 1:02 pm
by Nutsy
Ive managed to kill a few baite or baite clone minis...

Though you say that it turns on from USB power. You get a boot flash? The MCu actually running its program?
Maybe the Voltage regulator has fried. Thats an easy thing to fix if you can be arsed to... I mean theyre so cheap now.