"Black pill" board?

Generic boards that are not Maple or Maple mini clones, and don't contain the additional USB reset hardware
BenjiHansell
Posts: 16
Joined: Sun Mar 06, 2016 12:21 am

Re: "Black pill" board?

Postby BenjiHansell » Mon Jan 02, 2017 11:52 am

fredbox wrote:I believe I may have found the schematic for the black pill. If so it can be added to the wiki. My boards are on order, so I can't verify that this is the right drawing. The 1.5k USB resistor is shown on the schematic as R7. Schematic is here.


Seems to be the correct schematic. There is a diode between USB power and the regulator, but no VIN pin. Any idea why? It also seems to be missing the 22 ohm series resistors on USB D+ and D-.

Also, unlike the Maple Mini there is a 10 M ohm resistor in parallel with the crystal.

fredbox
Posts: 83
Joined: Tue Jul 07, 2015 4:44 pm

Re: "Black pill" board?

Postby fredbox » Sat Jan 21, 2017 5:06 pm

My boards arrived in this morning's mail. I was able to easily flash the bootloader and get them working. After flashing a blink sketch, the board enumerates properly:

Code: Select all

[Sat Jan 21 10:36:10 2017] usb 3-3: new full-speed USB device number 81 using xhci_hcd
[Sat Jan 21 10:36:10 2017] usb 3-3: New USB device found, idVendor=1eaf, idProduct=0004
[Sat Jan 21 10:36:10 2017] usb 3-3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[Sat Jan 21 10:36:10 2017] usb 3-3: Product: Maple
[Sat Jan 21 10:36:10 2017] usb 3-3: Manufacturer: LeafLabs
[Sat Jan 21 10:36:10 2017] usb 3-3: ep 0x82 - rounding interval to 1024 microframes, ep desc says 2040 microframes
[Sat Jan 21 10:36:10 2017] cdc_acm 3-3:1.0: ttyACM0: USB ACM device

I updated the wiki to include the bootloader flashing instructions for Linux.

User avatar
RogerClark
Posts: 5466
Joined: Mon Apr 27, 2015 10:36 am
Location: Melbourne, Australia
Contact:

Re: "Black pill" board?

Postby RogerClark » Sat Jan 21, 2017 8:46 pm

fredbox wrote:....

I updated the wiki to include the bootloader flashing instructions for Linux.


Thanks

michael_l
Posts: 211
Joined: Mon Aug 24, 2015 6:11 pm

Re: "Black pill" board?

Postby michael_l » Mon Feb 06, 2017 6:15 am

Just received these board. They seem much lighter than blue pill. There's no 5V pin.

Interesting thing is that st-link utility in Windows reports 128kB flash size.

michael_l
Posts: 211
Joined: Mon Aug 24, 2015 6:11 pm

Re: "Black pill" board?

Postby michael_l » Sat Feb 11, 2017 7:48 pm

Looks like I'm having some sort of connectivity issues with this board. I have flashed latest bootloader and it enumerates OK. But occasionally connecting to USB serial port does not work i.e. the connection does not open even the com port is visible in windows. Any hints how to start troubleshooting ?


Return to “Generic STM32F103”

Who is online

Users browsing this forum: No registered users and 2 guests