Page 1 of 1

[SOLVED] Can't find the DFU device: [1EAF:0003]

Posted: Fri Jan 05, 2018 4:53 pm
by jrsikken
I've been working with the STM32F103C8 blue pill for a while and created a product with it. ... c-load-r2/

Since recently I can't load any new sketches over USB serial.
I get below message on my W10/x64, I use Arduino. 1.8.4

Code: Select all

Archiving built core (caching) in: C:\Users\jrsik\AppData\Local\Temp\arduino_cache_936130\core\core_stm32duino_STM32F1_genericSTM32F103C_device_variant_STM32F103C8,upload_method_DFUUploadMethod,cpu_speed_speed_72mhz,opt_osstd_c873110d54e089b63cbd9341bdfc6ef7.a
Sketch uses 43648 bytes (66%) of program storage space. Maximum is 65536 bytes.
Global variables use 4408 bytes (21%) of dynamic memory, leaving 16072 bytes for local variables. Maximum is 20480 bytes.
maple_loader v0.1
Resetting to bootloader via DTR pulse
Searching for DFU device [1EAF:0003]...
dfu-util - (C) 2007-2008 by OpenMoko Inc.
Couldn't find the DFU device: [1EAF:0003]
This program is Free Software and has ABSOLUTELY NO WARRANTY
This is what I have tried
I succesfully re-loaded the bootloader. generic_boot20_pc13.bin, I am sure this is the right one.
I have also re-installed driver install_STM_COM_drivers.bat and install_driver.bat.
I also tried updating driver from device manager and selected the same folder were STM_COM_drivers.bat and install_driver.bat are located.
I am sure I have the correct resistor in paralel to USB.
I am sure I selected the right COM port and the right board (generic STM32F103C series)
I have used the latest Arduino board files and also a couple versions before.
I have also removed and reinstalled the stm32 package for the bluepil in C:\Users\jrsik\AppData\Local\Arduino15\Packages.
It doesn't help to press the reset button when I see Uploading

The difference between now and when it worked, was that previously I used an W7 laptop and now I am using my W10/x64 laptop.

DOes anyone have another clue?

Re: Couldn't find the DFU device: [1EAF:0003]

Posted: Fri Jan 05, 2018 6:21 pm
by stevestrong
Set BOOT0 to 1 and BOOT1 to 0,reset and check the device manager whether it recognizes the board or not.
If yes, then your USB driver was installed ok, otherwise not.
Did you run the install BAT files in a CMD window opened with admin rights?

Re: Couldn't find the DFU device: [1EAF:0003]

Posted: Fri Jan 05, 2018 7:13 pm
by jrsikken
With both BOOT0 and BOOT1 set to 0, it shows up as USB Serial Device and not as Maple.
I removed the driver and installed driver as administrator: Maple DFU driver, Maple Serial driver, and Serial STM driver.
When I plugged in the USB is says : setting up 'Maple' and then it shows up as USB Serial Device (COM4)
With boot0 to 1 and boot1 to 0 the board is not recognized.

Re: Couldn't find the DFU device: [1EAF:0003]

Posted: Fri Jan 05, 2018 7:18 pm
by Pito
I've done a clean install in win10 x64 (VB) (Ard 1.8.5 and latest Roger).
Maple Serial 0004 is there, but Maple DFU 0003 is missing. Tried with Zadig all the tricks, but it shows Maple Serial only.
@steve: Is this what you see when running cmd as admin? :

Code: Select all

Installing Maple DFU driver...
Extracting driver files...
Installing driver(s)...

Installing Maple Serial driver...
Extracting driver files...
Installing driver(s)...
  USB\VID_1EAF&PID_0004&REV_0200: Success

Press any key to continue . . .
PS: It could be it is caused by the VirtualBox as it switches the usb enum host/guest.. So let it be...

Re: Couldn't find the DFU device: [1EAF:0003]

Posted: Fri Jan 05, 2018 7:19 pm
by jrsikken
The drivers installation files were on a virtual R:\ drive, that was the problem.
When I moved them to C:\ and installed the driver it showed up as Maple Serial (COM4) and I could program the board!
Thanks for your suggestions. It helped me find the solution.