Page 1 of 1

Error with STM32Nucleo Board on Arduino 1.6.8

Posted: Thu Mar 09, 2017 6:47 am
by keyshavmor2611
Dear All,

I loaded the latest library for STM32 on Arduino. I unfortunately am not able to build even A LED Blink code on the Arduino 1.6.8. I am getting an error saying exec: "/bin/arm-none-eabi-g++": file does not exist
Error compiling for board Generic STM32F103R series.

The board works fine on other IDE like Keil and TrueStudio.

Please help.

Thanks.

Re: Error with STM32Nucleo Board on Arduino 1.6.8

Posted: Thu Mar 09, 2017 6:50 am
by RogerClark
2 things

1. You probably did not install the ARM compiler, (see the install instructions that describe how to install the Arduino Zero or Due to get the ARM compiler)
2. 1.6.8 is a very very old version of the IDE, I can't remember if we support it still. You should upgrade to much newer version e.g. 1.8

Re: Error with STM32Nucleo Board on Arduino 1.6.8

Posted: Thu Mar 09, 2017 7:32 am
by keyshavmor2611
Hey thanks for the swift reply. Where would I get the arm compiler which you mentioned? Could you please share a link?

I will immediately upgrade to 1.8

Re: Error with STM32Nucleo Board on Arduino 1.6.8

Posted: Thu Mar 09, 2017 8:33 am
by BennehBoy
Open up the Arduino IDE

Go to the tools menu, then to the board option, and click the sub menu option of Boards Manager.

Install the 'Arduino SAM Boards' option.

Re: Error with STM32Nucleo Board on Arduino 1.6.8

Posted: Thu Mar 09, 2017 9:11 am
by keyshavmor2611
Hey thanks a lot bennehboy. I will try to see how it works. If it doesn't, I will get back to you

Re: Error with STM32Nucleo Board on Arduino 1.6.8

Posted: Thu Mar 09, 2017 9:37 am
by RogerClark
Checkout my videos on youtube, I'm sure I've done one showing how to do it, albeit on a older version of the IDE