Error with STM32Nucleo Board on Arduino 1.6.8

STM32F103 Nucleo boards e.g. STM Nucleo F103RB
Post Reply
keyshavmor2611
Posts: 3
Joined: Thu Mar 09, 2017 6:40 am

Error with STM32Nucleo Board on Arduino 1.6.8

Post by keyshavmor2611 » Thu Mar 09, 2017 6:47 am

Dear All,

I loaded the latest library for STM32 on Arduino. I unfortunately am not able to build even A LED Blink code on the Arduino 1.6.8. I am getting an error saying exec: "/bin/arm-none-eabi-g++": file does not exist
Error compiling for board Generic STM32F103R series.

The board works fine on other IDE like Keil and TrueStudio.

Please help.

Thanks.

User avatar
RogerClark
Posts: 7146
Joined: Mon Apr 27, 2015 10:36 am
Location: Melbourne, Australia
Contact:

Re: Error with STM32Nucleo Board on Arduino 1.6.8

Post by RogerClark » Thu Mar 09, 2017 6:50 am

2 things

1. You probably did not install the ARM compiler, (see the install instructions that describe how to install the Arduino Zero or Due to get the ARM compiler)
2. 1.6.8 is a very very old version of the IDE, I can't remember if we support it still. You should upgrade to much newer version e.g. 1.8

keyshavmor2611
Posts: 3
Joined: Thu Mar 09, 2017 6:40 am

Re: Error with STM32Nucleo Board on Arduino 1.6.8

Post by keyshavmor2611 » Thu Mar 09, 2017 7:32 am

Hey thanks for the swift reply. Where would I get the arm compiler which you mentioned? Could you please share a link?

I will immediately upgrade to 1.8

User avatar
BennehBoy
Posts: 420
Joined: Thu Jan 05, 2017 8:21 pm
Location: Yorkshire
Contact:

Re: Error with STM32Nucleo Board on Arduino 1.6.8

Post by BennehBoy » Thu Mar 09, 2017 8:33 am

Open up the Arduino IDE

Go to the tools menu, then to the board option, and click the sub menu option of Boards Manager.

Install the 'Arduino SAM Boards' option.
-------------------------------------
https://github.com/BennehBoy

keyshavmor2611
Posts: 3
Joined: Thu Mar 09, 2017 6:40 am

Re: Error with STM32Nucleo Board on Arduino 1.6.8

Post by keyshavmor2611 » Thu Mar 09, 2017 9:11 am

Hey thanks a lot bennehboy. I will try to see how it works. If it doesn't, I will get back to you

User avatar
RogerClark
Posts: 7146
Joined: Mon Apr 27, 2015 10:36 am
Location: Melbourne, Australia
Contact:

Re: Error with STM32Nucleo Board on Arduino 1.6.8

Post by RogerClark » Thu Mar 09, 2017 9:37 am

Checkout my videos on youtube, I'm sure I've done one showing how to do it, albeit on a older version of the IDE

Post Reply