[SOLVED] GY-271 Compass is not recognised

Post here first, or if you can't find a relevant section!
Post Reply
Posts: 3
Joined: Sun Oct 08, 2017 2:36 pm

[SOLVED] GY-271 Compass is not recognised

Post by shauns » Wed Nov 01, 2017 10:32 am


I was struggling with a GY-271 Compass breakout board that I bought through Amazon. Genuine GY-271 and GY-273 devices use a Honeywell chip, either the HMC5883 or HMC5883L. The boards I bought have an address of 0x0D which I though was odd until I actually looked at the chips on the boards. It turns out the chips are QMC5883 devices. They are similar to but not the same as the Honeywell devices. After some searching, I found the datasheet here: https://github.com/luckypm/commn-inform ... 1.0%20.pdf and an Arduino library here https://github.com/mechasolution/Mecha_QMC5883L. I have tried this on an Arduino Due and it works. I have not had a chance to try this on an stm32 board yet but at least I am making progress.

I just hope this helps someone avoid wasting an entire afternoon. :D



Post Reply