STlink v2 not detect as serial port

Post Reply
hamdi
Posts: 3
Joined: Tue Feb 21, 2017 11:19 am

STlink v2 not detect as serial port

Post by hamdi » Tue Feb 21, 2017 12:28 pm

hi everyone,
im newbie for stm32, i use arduino IDE to program it. I using STM32F4 discovery, arduino 1.6.13, SAM borad arduino arm cortex m3 version 16.11 and linux ubuntu 14.04 amd64. I use usb line to STlink on board but in arduino IDE no serial port detect as ttyACM or ttyUSB.
the regex list of tty detect as :
/dev/tty /dev/tty23 /dev/tty39 /dev/tty54 /dev/ttyS10 /dev/ttyS26
/dev/tty0 /dev/tty24 /dev/tty4 /dev/tty55 /dev/ttyS11 /dev/ttyS27
/dev/tty1 /dev/tty25 /dev/tty40 /dev/tty56 /dev/ttyS12 /dev/ttyS28
/dev/tty10 /dev/tty26 /dev/tty41 /dev/tty57 /dev/ttyS13 /dev/ttyS29
/dev/tty11 /dev/tty27 /dev/tty42 /dev/tty58 /dev/ttyS14 /dev/ttyS3
/dev/tty12 /dev/tty28 /dev/tty43 /dev/tty59 /dev/ttyS15 /dev/ttyS30
/dev/tty13 /dev/tty29 /dev/tty44 /dev/tty6 /dev/ttyS16 /dev/ttyS31
/dev/tty14 /dev/tty3 /dev/tty45 /dev/tty60 /dev/ttyS17 /dev/ttyS4
/dev/tty15 /dev/tty30 /dev/tty46 /dev/tty61 /dev/ttyS18 /dev/ttyS5
/dev/tty16 /dev/tty31 /dev/tty47 /dev/tty62 /dev/ttyS19 /dev/ttyS6
/dev/tty17 /dev/tty32 /dev/tty48 /dev/tty63 /dev/ttyS2 /dev/ttyS7
/dev/tty18 /dev/tty33 /dev/tty49 /dev/tty7 /dev/ttyS20 /dev/ttyS8
/dev/tty19 /dev/tty34 /dev/tty5 /dev/tty8 /dev/ttyS21 /dev/ttyS9
/dev/tty2 /dev/tty35 /dev/tty50 /dev/tty9 /dev/ttyS22
/dev/tty20 /dev/tty36 /dev/tty51 /dev/ttyprintk /dev/ttyS23
/dev/tty21 /dev/tty37 /dev/tty52 /dev/ttyS0 /dev/ttyS24
/dev/tty22 /dev/tty38 /dev/tty53 /dev/ttyS1 /dev/ttyS25

but when i check it on command line (lsusb) it return detect the STlink device :

Bus 002 Device 004: ID 04f2:b044 Chicony Electronics Co., Ltd Acer CrystalEye Webcam
Bus 002 Device 003: ID 0483:3748 STMicroelectronics ST-LINK/V2
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

i have install the package from github : stlink, openocd, QStlink, libstlink, texinfo but STlink is still cannot detect as serial port on linux.
what should i do for the issue?
help me please
thank you

victor_pv
Posts: 1468
Joined: Mon Apr 27, 2015 12:12 pm

Re: STlink v2 not detect as serial port

Post by victor_pv » Tue Feb 21, 2017 3:53 pm

hamdi wrote:
i have install the package from github : stlink, openocd, QStlink, libstlink, texinfo but STlink is still cannot detect as serial port on linux.
what should i do for the issue?
help me please
thank you
I think that is correct, stlink V2 does not show as a serial port. I believe only the stlinks that come integrated in ST boards have the com port function.

hamdi
Posts: 3
Joined: Tue Feb 21, 2017 11:19 am

Re: STlink v2 not detect as serial port

Post by hamdi » Tue Feb 21, 2017 6:16 pm

victor_pv wrote:
I think that is correct, stlink V2 does not show as a serial port. I believe only the stlinks that come integrated in ST boards have the com port function.
ok :D thanks a lot victor_pv, I thought Im wrong on do it

User avatar
RogerClark
Posts: 6370
Joined: Mon Apr 27, 2015 10:36 am
Location: Melbourne, Australia
Contact:

Re: STlink v2 not detect as serial port

Post by RogerClark » Tue Feb 21, 2017 8:39 pm

I think perhaps only Nucleo boards have Serial as part of their STLink.

I am pretty sure one of my Discovery boards only has STLink SWD .

there is a link in another thread to someone who "hacks" stlinks and I think he has a method to load a different version of STLink onto virtually any board.
But you have to modify the stlink files yourself, he only describes the process of analysing and modifying them.

hamdi
Posts: 3
Joined: Tue Feb 21, 2017 11:19 am

Re: STlink v2 not detect as serial port

Post by hamdi » Tue Feb 21, 2017 10:24 pm

RogerClark wrote:I think perhaps only Nucleo boards have Serial as part of their STLink.

I am pretty sure one of my Discovery boards only has STLink SWD .

there is a link in another thread to someone who "hacks" stlinks and I think he has a method to load a different version of STLink onto virtually any board.
But you have to modify the stlink files yourself, he only describes the process of analysing and modifying them.
yes alright. I think the serial port just comes from stlink USB on board, like arduino. after I know stlink didnt return the serial port and I follow this thread http://vedder.se/2012/07/usb-serial-on-stm32f4/ finally I have the serial port from USB OTG on ttyACM0.
thanks a lot for your help victor_pv and RogerClark

MaxT72
Posts: 1
Joined: Wed Feb 01, 2017 2:43 am

Re: STlink v2 not detect as serial port

Post by MaxT72 » Fri Mar 24, 2017 12:46 pm

STLink V2 only has the debug interface.
V2 is still present on a lot of discovery boards and eval boards that were designed more than 3/4 years ago
Standalone STLink are V2

STLink V2-1 has the debug interface, the mass storage programming interface (a virtual drive where you copy your binary for easy programming) and the virtual COM port.
V2-1 is present on all new boards, like all the nucleo boards and the most recent discovery boards and eval boards.
There is no standalone V2-1. If you need one, cut it out from a nucleo board.

vargham
Posts: 17
Joined: Thu Jan 26, 2017 3:49 pm

Re: STlink v2 not detect as serial port

Post by vargham » Fri Mar 24, 2017 1:30 pm

MaxT72 wrote: V2-1 is present on all new boards, like all the nucleo boards and the most recent discovery boards and eval boards.
Yes. I have many F429 discovery boards. Older one has V2, newer one has V2-1. I hate V2-1, so uploaded V2 firmware to V2-1. The hardware is identical.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest