chaining st-info commands

Post Reply
zmemw16
Posts: 1422
Joined: Wed Jul 08, 2015 2:09 pm
Location: St Annes, Lancs,UK

chaining st-info commands

Post by zmemw16 » Sat Dec 19, 2015 11:14 pm

in a puzzle, i'm trying to read back the flash of my one and only working with a display maple mini

arduino-stm32 as of 161215-1750, arduino 1.6.5r5, cortex-m3 1.6.5 & esp8266-2.0.0 on debian jessie
totally new clean install
i get the same result working out of

Code: Select all

stephen@i7:~/sketchbook/hardware/Arduino_STM32/tools/linux/stlink$
could someone please try

Code: Select all

st-info --flash; st-info --chipid
st-info --flash
st-info --chipid
that first line is what tried originally
i'd expected this

Code: Select all

stephen@i7:~$ st-info --flash; st-info --chipid
0x20000
0x0410
stephen@i7:~$ st-info --flash
0x20000
stephen@i7:~$ st-info --chipid
0x0410
stephen@i7:~$
i got this

Code: Select all

stephen@i7:~$st-info --flash; st-info --chipid
stephen@i7:~$
stephen@i7:~$ st-info --flash
0x20000
stephen@i7:~$ st-info --chipid
0x0410
stephen@i7:~$
only if i unplugged and plugged the st-link back in between steps
repeats of the same command seem to work or is it just outputting the last something or other?

stephen

zmemw16
Posts: 1422
Joined: Wed Jul 08, 2015 2:09 pm
Location: St Annes, Lancs,UK

Re: chaining st-info commands

Post by zmemw16 » Sun Dec 20, 2015 12:13 pm

well, it's funny what a few hours sleep does to me and a power off to the laptop.
for fun, programmed the blink sketch into a maple mini, updated a st-link and still
couldn't read the flash all via a virtualbox xp.

this is a blue pill, the chaining of st-info worked and then it jumped
out at me as i'm used to seeing 0x20000
stephen@i7:~$ comms
lrwxrwxrwx 1 root root 7 Dec 20 12:00 maple_0 -> ttyACM0
crw-rw-r-- 1 root dialout 166, 0 Dec 20 12:00 ttyACM0
stephen@i7:~$ st-info --flash;st-info --sram ; st-info --chipid;st-info --descr
0x10000
0x5000
0x0410
F1 Medium-density device
i normally use konsole, now i'm wondering if the settings got fuddled?
xterm?
stephen
back to reading the flash back ... ...

User avatar
RogerClark
Posts: 6917
Joined: Mon Apr 27, 2015 10:36 am
Location: Melbourne, Australia
Contact:

Re: chaining st-info commands

Post by RogerClark » Sun Dec 20, 2015 9:07 pm

its probably a question for STMs own forum, as the STLink CLI is their software

Post Reply