STM32F407 Discovery Compiling Issues

Limited support for STM32F4 Discovery, Nucleo and custom F4 boards
User avatar
mrburnette
Posts: 1794
Joined: Mon Apr 27, 2015 12:50 pm
Location: Greater Atlanta
Contact:

Re: STM32F407 Discovery Compiling Issues

Post by mrburnette » Wed Jun 08, 2016 1:53 pm

Touseef wrote:
martinayotte wrote:What do you wish to accomplish with this "while(!Serial);" ?
I don't see the goal here ...
Martin I just want to write a simple code using which I can blink LEDs on pin 12 and 13. Need guidance on this one.

Then my next goal will be to control a DC servo motor with my board but right now blinking LEDs are my priority.
While specific to the Maple Mini, you should be able to just change the pin definition for your variety of board. My examples:
https://github.com/rogerclarkmelbourne/ ... es/General

Now with that said, I wish to ask you to please use the Google site search a bit more often. We are a small forum community, most of the senior members have day jobs and little time for newbie nonsense. You need to jumpstart your understanding by doing some self-study.
Access a google site search like:
<terms to search> site:stm32duino.com
Example: http://www.google.com/search?client=ope ... 2duino.com

Ray
Some Projects

Touseef
Posts: 16
Joined: Sat Jun 04, 2016 9:25 am

Re: STM32F407 Discovery Compiling Issues

Post by Touseef » Wed Jun 08, 2016 3:08 pm

OK I've uploaded your code and it shows the same error "No Target Connected" after uploading the complete code.
Attachments
skec.png
skec.png (12.35 KiB) Viewed 452 times

User avatar
mrburnette
Posts: 1794
Joined: Mon Apr 27, 2015 12:50 pm
Location: Greater Atlanta
Contact:

Re: STM32F407 Discovery Compiling Issues

Post by mrburnette » Wed Jun 08, 2016 3:13 pm

Touseef wrote:<...>
shows the same error "No Target Connected" after uploading the complete code.
Then you have
[*]an IDE configuration issue
[*]a bad SWD connection/cable

Or some other malady.


Ray

User avatar
martinayotte
Posts: 1191
Joined: Mon Apr 27, 2015 1:45 pm

Re: STM32F407 Discovery Compiling Issues

Post by martinayotte » Wed Jun 08, 2016 4:32 pm

You should not bother about the "No target connected", I think it is simply that it doesn't seems to be able to execute "reset".
Simply power-cycle your board to see it blinking.

User avatar
mrburnette
Posts: 1794
Joined: Mon Apr 27, 2015 12:50 pm
Location: Greater Atlanta
Contact:

Re: STM32F407 Discovery Compiling Issues

Post by mrburnette » Wed Jun 08, 2016 4:49 pm

Thanks, Martin!
I do not have an F4 Discovery Board ... but with as many questions as we get about these darn things, I should probably buy one just to punish myself :lol:

Ray

User avatar
martinayotte
Posts: 1191
Joined: Mon Apr 27, 2015 1:45 pm

Re: STM32F407 Discovery Compiling Issues

Post by martinayotte » Wed Jun 08, 2016 6:27 pm

Hi Ray, the "reset" issue is not only F4 related ...
For your punishment, you should purchase board like viewtopic.php?f=39&p=14454#p14450
With such punishments, it becomes a pleasure to be punished ... :lol:

Touseef
Posts: 16
Joined: Sat Jun 04, 2016 9:25 am

Re: STM32F407 Discovery Compiling Issues

Post by Touseef » Wed Jun 08, 2016 7:48 pm

mrburnette wrote:
Touseef wrote:<...>
shows the same error "No Target Connected" after uploading the complete code.
Then you have
[*]an IDE configuration issue
[*]a bad SWD connection/cable

Or some other malady.


Ray
@ mrburnette
OK I think the "No target Connected" issue is solved. Now how can I blink those LEDs because the code you gave

Code: Select all

void setup() {
    // Set up the built-in LED pin as an output:
    pinMode(33, OUTPUT);
}

void loop() {
    digitalWrite(33,!digitalRead(33));// Turn the LED from off to on, or on to off
    delay(1000);          // Wait for 1 second (1000 milliseconds)
}
is targeting pin 33 but the on board LEDs are attached with PD12 and PD13. So how can I target these two pins to turn on the LEDs.

User avatar
RogerClark
Posts: 6338
Joined: Mon Apr 27, 2015 10:36 am
Location: Melbourne, Australia
Contact:

Re: STM32F407 Discovery Compiling Issues

Post by RogerClark » Wed Jun 08, 2016 9:19 pm

For a start, dont use pin numbers, use the official STM names for the pins, which you already quoted in your post.

User avatar
mrburnette
Posts: 1794
Joined: Mon Apr 27, 2015 12:50 pm
Location: Greater Atlanta
Contact:

Re: STM32F407 Discovery Compiling Issues

Post by mrburnette » Wed Jun 08, 2016 10:40 pm

martinayotte wrote:Hi Ray, the "reset" issue is not only F4 related ...
For your punishment, you should purchase board like viewtopic.php?f=39&p=14454#p14450
With such punishments, it becomes a pleasure to be punished ... :lol:
Yes, I have been following the postings there... but, I do not have a use for such a beast of a chip (though I understand the desire) ...
the board is probably shipped in a black leather carry-pouch and a miniature whip. :roll:
'tis would give a new meaning to chip torture.


Ray

User avatar
martinayotte
Posts: 1191
Joined: Mon Apr 27, 2015 1:45 pm

Re: STM32F407 Discovery Compiling Issues

Post by martinayotte » Wed Jun 08, 2016 10:59 pm

mrburnette wrote: the board is probably shipped in a black leather carry-pouch and a miniature whip. :roll:
'tis would give a new meaning to chip torture.
And the chip can answer "meoww !" :lol:

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests