Any support or what do i need to get this working?

Limited support for STM32F4 Discovery, Nucleo and custom F4 boards
Nutsy
Posts: 260
Joined: Sun Jul 24, 2016 4:26 pm

Any support or what do i need to get this working?

Post by Nutsy » Fri Dec 22, 2017 12:12 am

So yes, i have this board on the way. Looking at the Wiki i see the discovery is supported. Same chip, but i guess different layout

https://www.aliexpress.com/item/STM32-A ... 02179.html

So what would it take to get this to work?
Has anyone used this?

stevestrong
Posts: 2067
Joined: Mon Oct 19, 2015 12:06 am
Location: Munich, Germany
Contact:

Re: Any support or what do i need to get this working?

Post by stevestrong » Fri Dec 22, 2017 9:39 am

Looks similar to the generic black F4 board, just that it has more flash (and RAM?).
Depending on what interfaces you need:
- for "standard" stuff you could try the Roger's repo (or maybe my repo because it is a bit more developed), see http://stm32duino.com/viewtopic.php?f=39&t=1976.
- for any "special" stuff you should use the official STM core or Daniel's generic core.

zmemw16
Posts: 1684
Joined: Wed Jul 08, 2015 2:09 pm
Location: St Annes, Lancs,UK

Re: Any support or what do i need to get this working?

Post by zmemw16 » Fri Dec 22, 2017 4:18 pm

that's a black devils cross without the cross silk screening.

it should work with STM32GENERIC, mine do :-)
there're multiple versions of STM32GENERIC, daniel, huaweix??

stephen

Nutsy
Posts: 260
Joined: Sun Jul 24, 2016 4:26 pm

Re: Any support or what do i need to get this working?

Post by Nutsy » Fri Dec 22, 2017 8:19 pm

Whats a black devils cross board? Never heard of that, and google cant find anything

zmemw16
Posts: 1684
Joined: Wed Jul 08, 2015 2:09 pm
Location: St Annes, Lancs,UK

Re: Any support or what do i need to get this working?

Post by zmemw16 » Sat Dec 23, 2017 11:10 am

a "different makers(?) version" of this Black 407ZGT came with a 4 pointed cross silk screen center'd on the processor. board pinouts are the same.
that reminded of an A10 aircraft with German markings, nick named as the Devils Cross in Tom Clancy's Red Storm Rising.
i've used it with both of the STM32GENERIC cores; dan- & hua-. and it's listed in their board manager as a Black F407, a top level menu then selects the particular VE/ZE/ZG variant.

one of advertisers had a reference to 'compatible tft displays', albeit a bit pricey, i've since seen tft displays with identical "pins count & pin naming" quite a bit cheaper.

stephen

Nutsy
Posts: 260
Joined: Sun Jul 24, 2016 4:26 pm

Re: Any support or what do i need to get this working?

Post by Nutsy » Sun Jan 21, 2018 11:41 am

As you have the board, I could do with some more info...
Are there any example programs for this board? My board came with a mass storage program making the onboard flash and sd reader viewable on the computer... (just about its unstable though)

In the STM32GENERIC theres a a zgt (M4 DEMO) listed... is that this board?

Something else I cant find is the info on the flash or the sd reader... What pins or serial/SPI/i2c are they connected to?
Also what pins are the led indicators connected to?

Also program upload and serial print debugging... Whats the best way to do that? From what i can tell the USB on board cant be used for any of that?

Ive used an STlink to reflash some f103 boards but i dont remember it being used for serial debugging?

So whats the best way to go about it all?

zmemw16
Posts: 1684
Joined: Wed Jul 08, 2015 2:09 pm
Location: St Annes, Lancs,UK

Re: Any support or what do i need to get this working?

Post by zmemw16 » Sun Jan 21, 2018 1:16 pm

if you believe the pics are of that board, then it's a Black 407 ZET, zoom on 2nd pic and you can make out the ZE

there's also a soic footprint on the back, some people already have done timing tests on SRAM and have posted their results.
2 makes. apart from fast and faster, samsung is one :)
yes, i have 10 of each for installation sometime. getting my resources together is worse than trying to herd a cat.

the VET chip is smaller and mounted square to the pcb, not rotated 45 degs
the ZGT is much the same size, way higher pin count and higher pin count side connectors.

i thought i'd posted connectors and such, i'll gather what i've got and post/repost it.

all 3 are in at least one of the STM32GENERIC cores, sub-menu under Black F407 istr
unsure on the libmaple cores.

stephen

Nutsy
Posts: 260
Joined: Sun Jul 24, 2016 4:26 pm

Re: Any support or what do i need to get this working?

Post by Nutsy » Sun Jan 21, 2018 1:31 pm

The pics on th site are indeed the VET I do have the zgt though...

But what about the propper way to upload and debug?

zmemw16
Posts: 1684
Joined: Wed Jul 08, 2015 2:09 pm
Location: St Annes, Lancs,UK

Re: Any support or what do i need to get this working?

Post by zmemw16 » Sun Jan 21, 2018 2:10 pm

just checked the pics again, 2nd & 3rd show ZET's
i always use st-link method, mainly 20way cable route with blue/white egg shape st-link, although i use the usb stick st-link type for blue pill etc
i've never had any real success with the other methods, worst i've had on st-link is the odd press reset or even rarer a power disconnect/connect

tft connectors change in size 34 v 36 and also change from header to socket on these boards.
pin name wise there are a number of displays that seem usable.

srp

Nutsy
Posts: 260
Joined: Sun Jul 24, 2016 4:26 pm

Re: Any support or what do i need to get this working?

Post by Nutsy » Sun Jan 21, 2018 3:06 pm

ZET sorry :p too many chip names gets confusing :D

So yeah I have one of those cheap STlink usb dongles...

So that for firmware uploading then.

What about debugging? Can the stlink be used? i assume its not by the normal serial print?

Post Reply