Uploading Sketch to Maple mini from Arduino 1.6.9 [SOLVED]

Development environment specific, Arduino, Eclipse, VS2013,Em::Blocks etc
navintiwari08
Posts: 16
Joined: Sat Aug 22, 2015 3:54 pm

Re: Uploading Sketch to Maple mini from Arduino 1.6.9

Postby navintiwari08 » Fri Aug 12, 2016 11:09 am

Code: Select all

ATTRS{idVendor}=="1eaf" ATTRS{idProduct}=="0004", ENV{ID_MM_DEVICE_IGNORE}="1"


I tried that but it didn't work. There is no problem in resetting the board. When I hit upload, the maple reset is triggered as I can see the LED blink fast. But it fails to upload the sketch and throws invalid dfu signature error and says dfu device not found. When I put the board in perpetual bootloader mode and then try uploading sketch, it doest that fine and resets and executes the uploaded program. I'm not sure if I'm missing something.

devan
Posts: 39
Joined: Sat May 14, 2016 1:45 am

Re: Uploading Sketch to Maple mini from Arduino 1.6.9

Postby devan » Fri Aug 12, 2016 3:36 pm

Oh, in that case, I've encountered that exact symptom before.

Try tweaking the delay in the maple_upload script in the Arduino_STM32 directory under tools/linux or tools/linux64. On my laptop, a 1000ms delay works consistently, whereas the default of 750ms never worked.

navintiwari08
Posts: 16
Joined: Sat Aug 22, 2015 3:54 pm

Re: Uploading Sketch to Maple mini from Arduino 1.6.9

Postby navintiwari08 » Sat Aug 13, 2016 10:27 am

Thanks a lot, Devan!!

1500 ms works fine with my desktop pc. I can now upload the sketch with ease. Case closed!

-Navin


Return to “IDE's”

Who is online

Users browsing this forum: No registered users and 2 guests