[SOLVED] Problems with the compiler after installing stm32 core

Development environment specific, Arduino, Eclipse, VS2013,Em::Blocks etc
Post Reply
FRANCISCOGIMENO
Posts: 38
Joined: Wed Nov 08, 2017 12:30 pm

[SOLVED] Problems with the compiler after installing stm32 core

Post by FRANCISCOGIMENO » Mon Dec 04, 2017 1:15 pm

Hello friends,
A very strange thing happens to me. after installing stm32 core in the
arduino ide, I select a project that worked correctly for Mega 2650
compiles it without errors and I transfer it to the mega, but what is programmed does not work well.

If I take the direct Hex file that I had saved a copy without modifying it by the compiler and I transfer it to the mega that copy if it works correctly.

The same compiled and transferred program does not work well.

I do not know what may have changed after installing the stm32 core.

Maybe a reference to some bookstore ..

Does anyone have any ideas or has it happened to him?

I searched the forum and on the internet and I do not find anything related.

I have the latest version of the arduino ide

Greetings and thank you.
Last edited by FRANCISCOGIMENO on Mon Dec 04, 2017 10:19 pm, edited 1 time in total.

User avatar
zoomx
Posts: 567
Joined: Mon Apr 27, 2015 2:28 pm
Location: Mt.Etna, Italy

Re: Problems with the compiler after installing stm32 core

Post by zoomx » Mon Dec 04, 2017 2:38 pm

I believe that it is a library problem. Set the IDE on verbose and check which library are used.

FRANCISCOGIMENO
Posts: 38
Joined: Wed Nov 08, 2017 12:30 pm

Re: Problems with the compiler after installing stm32 core

Post by FRANCISCOGIMENO » Mon Dec 04, 2017 10:18 pm

Ok thanks to the end her a library that I had to reinstall.
But I do not know why it has been modified because I have not touched it. but good and this one.

Thanks for everything.

Post Reply