hardware & libraries directories not seen ?

External hardware connected to the STM32 board
Post Reply
zmemw16
Posts: 1584
Joined: Wed Jul 08, 2015 2:09 pm
Location: St Annes, Lancs,UK

hardware & libraries directories not seen ?

Post by zmemw16 » Sat Jul 02, 2016 9:52 pm

i'm using 1.6.9 64 bit on i7 laptop debian jessie 8.3'ish

i'm no longer seeing the sketchbook/hardware or sketchbook/libraries directories.
i'm wondering if this is down moving to 1.6.9 from 1.6.5?
more importantly how do i get them back? i'm missing the arduino_STM32 example sketches.
the stm32 libraries are found e.g. OneWireSTM

stephen

User avatar
RogerClark
Posts: 7541
Joined: Mon Apr 27, 2015 10:36 am
Location: Melbourne, Australia
Contact:

Re: hardware & libraries directories not seen ?

Post by RogerClark » Sat Jul 02, 2016 9:56 pm

I moved the examples to a faux lib a few weeks ago, so they can be accessed from the menus.

I posted about it. (sorry i cant find the link and I am posting from my phone, which makes finding stuff difficult)

zmemw16
Posts: 1584
Joined: Wed Jul 08, 2015 2:09 pm
Location: St Annes, Lancs,UK

Re: hardware & libraries directories not seen ?

Post by zmemw16 » Sat Jul 02, 2016 9:58 pm

i remember thinking oh nice about that.

any thoughts why they've gone walkies?

stephen

User avatar
martinayotte
Posts: 1234
Joined: Mon Apr 27, 2015 1:45 pm

Re: hardware & libraries directories not seen ?

Post by martinayotte » Sun Jul 03, 2016 1:40 am

Is it only Windows related bug again ?

zmemw16
Posts: 1584
Joined: Wed Jul 08, 2015 2:09 pm
Location: St Annes, Lancs,UK

Re: hardware & libraries directories not seen ?

Post by zmemw16 » Mon Jul 04, 2016 11:29 am

i'm Linux - Debian Jessie 8.x 64 bit Arduino 1.6.9r0

curiously my other laptop shows the hardware and library folder when looking in examples menu.
well it did yesterday! :shock:

what gets written when exiting arduino? does preferences.txt?
off to find the master... ... rename ./.arduino15 or my equivalent :)
there was me thinking i won't need to do that again.

ok, deleted ./.arduino1.6.9r0
first run - setup font, compiler/upload warnings etc and sketchbook
second run - board manager, added m3
third run - selected maple mini, arduino_stm32 now listed under examples, not the hardware/libraries directories though.

stephen

Post Reply