Evaluation boards arrived from STM

The official STMicroelectronics Arduino core
User avatar
RogerClark
Posts: 5467
Joined: Mon Apr 27, 2015 10:36 am
Location: Melbourne, Australia
Contact:

Evaluation boards arrived from STM

Postby RogerClark » Thu Sep 29, 2016 4:38 am

Guys

STM have sent me the Nucleo boards, which their code will eventually support.

These boards are

Nucleo L053
Nucleo F091
Nucleo F103
Nucleo F303
Nucleo F446
Nucleo L476


I already had a Nucleo F334, and I can't remember whether that was on their list to be supported or not.

I also have a Discovery F4, but I don't think STM intend to support the Discovery series at all - however I think a number of people on the forum have some form of Discovery F4, so I suspect we will end up supporting it in some way.

PS. The boards have taken a week by Fedex to get from France to Australia, because they were misslabled with the AT rather than AU country code, hence they have been from France to Austria and back 3 times before I rang Fedex to notify them that something was seriously wrong with the addressing of the package(s) - and managed to get them to update the labels

Its strange, as the delivery address was correct, so you;d imagine it would be all handled by bar codes, not by the country code printed on the box, but perhaps they still manually sort stuff!

User avatar
zoomx
Posts: 352
Joined: Mon Apr 27, 2015 2:28 pm
Location: Mt.Etna, Italy

Re: Evaluation boards arrived from STM

Postby zoomx » Thu Sep 29, 2016 8:02 am

:lol:

User avatar
Pito
Posts: 617
Joined: Sat Mar 26, 2016 3:26 pm
Location: Rapa Nui

Re: Evaluation boards arrived from STM

Postby Pito » Thu Sep 29, 2016 8:18 am

The barcode there on the label is generated from the destination address a person enters into their system..
And yes, Austria and Australia is the same destination for most parcel services :)

User avatar
RogerClark
Posts: 5467
Joined: Mon Apr 27, 2015 10:36 am
Location: Melbourne, Australia
Contact:

Re: Evaluation boards arrived from STM

Postby RogerClark » Thu Sep 29, 2016 8:34 am

Well if you want a laugh, here is the track log

Code: Select all

29/09/2016 - Thursday
13:49   Delivered      VICTORIA AU
   
09:23   On FedEx vehicle for delivery      DERRIMUT AU
   
08:21   At local FedEx facility      DERRIMUT AU
   
08:21   In transit      DERRIMUT AU
   
Package available for clearance
08:21   International shipment release - Import      DERRIMUT AU
   
28/09/2016 - Wednesday
11:59   In transit      SINGAPORE SG
   
08:31   In transit      SINGAPORE SG
   
04:26   In transit      GUANGZHOU CN
   
03:42   Departed FedEx location      GUANGZHOU CN
   
27/09/2016 - Tuesday
22:11   Arrived at FedEx location      GUANGZHOU CN
   
05:56   On FedEx vehicle for delivery      LEOBENDORF AT
   
04:19   In transit      ROISSY CHARLES DE GAULLE CEDEX FR
   
03:45   Departed FedEx location      ROISSY CHARLES DE GAULLE CEDEX FR
   
03:11   In transit      ROISSY CHARLES DE GAULLE CEDEX FR
   
00:29   Arrived at FedEx location      ROISSY CHARLES DE GAULLE CEDEX FR
   
26/09/2016 - Monday
22:44   In transit      WIEN AT
   
18:21   Arrived at FedEx location      ROISSY CHARLES DE GAULLE CEDEX FR
   
13:24   In transit      VIENNA AT
   
05:14   In transit      VIENNA AT
   
Tendered to authorized agent for final delivery
05:00   In transit      VIENNA AT
   
Package available for clearance
25/09/2016 - Sunday
00:33   In transit      ROISSY CHARLES DE GAULLE CEDEX FR
   
24/09/2016 - Saturday
19:39   Departed FedEx location      ROISSY CHARLES DE GAULLE CEDEX FR
   
18:35   Arrived at FedEx location      ROISSY CHARLES DE GAULLE CEDEX FR
   
03:55   Arrived at FedEx location      ROISSY CHARLES DE GAULLE CEDEX FR
   
23/09/2016 - Friday
20:01   In transit      CORBAS FR
   
20:01   Left FedEx origin facility      CORBAS FR
   
15:30   Picked up      VOREPPE FR
   
08:34   Shipment information sent to FedEx

User avatar
Pito
Posts: 617
Joined: Sat Mar 26, 2016 3:26 pm
Location: Rapa Nui

Re: Evaluation boards arrived from STM

Postby Pito » Thu Sep 29, 2016 1:59 pm

Your boards traveled around the globe :)
The most expensive boards ever :)

evildave_666
Posts: 27
Joined: Mon Apr 27, 2015 11:20 pm

Re: Evaluation boards arrived from STM

Postby evildave_666 » Sun Oct 02, 2016 11:45 pm

I picked up an L476 board this weekend, as my local brick and mortar source had them in stock.

User avatar
RogerClark
Posts: 5467
Joined: Mon Apr 27, 2015 10:36 am
Location: Melbourne, Australia
Contact:

Re: Evaluation boards arrived from STM

Postby RogerClark » Mon Oct 03, 2016 12:01 am

The L476 board does work, but I had an issue with the upload script, so I've pushed a totally new version of the nucleoflasher bat file to the tools repo

Also. I'll need to open another thread, as the L476 seems to have some problem with clock speed.

It appears to be running at 64Mhz not 80 Mhz. (See viewtopic.php?f=3&t=76&start=70#p18464 )

I've emailed STM and Wi6 and asked them to investigate as its a problem in the original code produced by Wi6Labs (or its by design that they only run a 80Mhz board at 64Mhz)

Apart from that, things like Blink and PWM work and also SPI works

User avatar
Wi6Labs
Posts: 16
Joined: Fri Sep 16, 2016 11:39 am
Location: Rennes, France
Contact:

Re: Evaluation boards arrived from STM

Postby Wi6Labs » Mon Oct 03, 2016 1:54 pm

Roger,

As we have said in our email reply we have chosen to run the L476 at 64MHz. You can change the clock configuration by setting the flag ENABLE_HIGH_SPEED (in hw_config.h) and recompile the library. The clock will be at 80MHz.

The L476 board does work, but I had an issue with the upload script, so I've pushed a totally new version of the nucleoflasher bat file to the tools repo

Could you explain us what issue did you have with the upload script? What Windows version are you using?

Thanks
Wi6Labs team

User avatar
GrumpyOldPizza
Posts: 166
Joined: Fri Apr 15, 2016 4:15 pm
Location: Denver, CO

Re: Evaluation boards arrived from STM

Postby GrumpyOldPizza » Mon Oct 03, 2016 3:06 pm

Wi6Labs wrote:Roger,

As we have said in our email reply we have chosen to run the L476 at 64MHz. You can change the clock configuration by setting the flag ENABLE_HIGH_SPEED (in hw_config.h) and recompile the library. The clock will be at 80MHz.

The L476 board does work, but I had an issue with the upload script, so I've pushed a totally new version of the nucleoflasher bat file to the tools repo

Could you explain us what issue did you have with the upload script? What Windows version are you using?

Thanks


If you enable 80MHz via ENABLE_HIGH_SPEED, then I2C will stop working.

User avatar
RogerClark
Posts: 5467
Joined: Mon Apr 27, 2015 10:36 am
Location: Melbourne, Australia
Contact:

Re: Evaluation boards arrived from STM

Postby RogerClark » Mon Oct 03, 2016 8:20 pm

Why wont I2C work at 80MHz?

does it end up going to fast ?


Return to “STM Core”

Who is online

Users browsing this forum: No registered users and 1 guest