Board Nucleo_64 (platform stm32, package STM32) is unknown

The official STMicroelectronics Arduino core
Post Reply
dberenguer
Posts: 6
Joined: Sun Aug 06, 2017 5:22 pm

Board Nucleo_64 (platform stm32, package STM32) is unknown

Post by dberenguer » Thu Dec 21, 2017 9:54 am

This is my first try with the STM32 cores for Arduino so I installed the cores from Tools->Boards Manager as explained in the wiki (https://github.com/stm32duino/wiki/wiki/Getting-Started). Then I selected "Nucleo-64" from Tools->Boards, "Nucleo L476RG" and finally tried to compile a simple Blink example. I'm always getting the error "Board Nucleo_64 (platform stm32, package STM32) is unknown". The same happens with other boards. Other boards from many different packages work without problems. BTW, I'm working on Ubuntu.

The following is the console output from the Arduino IDE:

/home/daniel/applications/arduino-1.8.3/arduino-builder -dump-prefs -logger=machine -hardware /home/daniel/applications/arduino-1.8.3/hardware -hardware /home/daniel/.arduino15/packages -tools /home/daniel/applications/arduino-1.8.3/tools-builder -tools /home/daniel/applications/arduino-1.8.3/hardware/tools/avr -tools /home/daniel/.arduino15/packages -built-in-libraries /home/daniel/applications/arduino-1.8.3/libraries -libraries /home/daniel/development/mysketches/libraries -fqbn=STM32:stm32:Nucleo_64:pnum=NUCLEO_L476RG,upload_method=MassStorage,xserial=none,usb=none,opt=osstd -ide-version=10803 -build-path /tmp/arduino_build_954547 -warnings=none -build-cache /tmp/arduino_cache_915460 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.CMSIS.path=/home/daniel/.arduino15/packages/arduino/tools/CMSIS/4.5.0 -prefs=runtime.tools.arm-none-eabi-gcc.path=/home/daniel/.arduino15/packages/STM32/tools/arm-none-eabi-gcc/6-2017-q2-update -prefs=runtime.tools.STM32Tools.path=/home/daniel/.arduino15/packages/STM32/tools/STM32Tools/2017.9.22 -verbose /home/daniel/applications/arduino-1.8.3/examples/01.Basics/Blink/Blink.ino

Board Nucleo_64 (platform stm32, package STM32) is unknown

Error compiling for board Nucleo-64.

Is maybe the automatic Boards Manager install system not working properly? Should I try to do a manual install instead?

Thanks for your time!

fpiSTM
Posts: 314
Joined: Fri Sep 16, 2016 12:33 pm
Location: Le Mans, France

Re: Board Nucleo_64 (platform stm32, package STM32) is unknown

Post by fpiSTM » Thu Dec 21, 2017 11:06 pm

Hum... strange.
You should have this path:
/home/daniel/.arduino15/packages/STM32/hardware/stm32/2017.11.24

Have you already install some STM32 core?
Maybe, some tmp file not well updated in:
/home/daniel/.arduino15/packages/

ex:
package_stm_index.json*

Could you try a fresh install?
Download Arduino archive.
Extract it.
Create a folder named "portable" in the arduino directory. (This will avoid to use the default local directory home/daniel/.arduino15)
Then install the core thanks the board manager.

Post Reply