Page 1 of 1

[SOLVED] having problem to upload code on stm32f103c with ftdi

Posted: Fri Dec 22, 2017 1:30 pm
by MAnand59
whenever I hit upload the console says "done uploading" but nothing changes on microcontroller...
and these are the error lines I get displayed on my console...help

Code: Select all

Archiving built core (caching) in: C:\Users\anand\AppData\Local\Temp\arduino_cache_674860\core\core_Arduino_STM32-master_STM32F1_genericSTM32F103C_device_variant_STM32F103C8,upload_method_DFUUploadMethod,cpu_speed_speed_72mhz,opt_osstd_411173639e4cf27cad066031e6806619.a
Sketch uses 13044 bytes (19%) of program storage space. Maximum is 65536 bytes.
Global variables use 2816 bytes (13%) of dynamic memory, leaving 17664 bytes for local variables. Maximum is 20480 bytes.
maple_loader v0.1
Resetting to bootloader via DTR pulse
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x000000007110b5db, pid=9540, tid=1216
#
# JRE version: Java(TM) SE Runtime Environment (9.0+11) (build 9.0.1+11)
# Java VM: Java HotSpot(TM) 64-Bit Server VM (9.0.1+11, mixed mode, tiered, compressed oops, g1 gc, windows-amd64)
# Problematic frame:
# C  [jSSC-2.8_x86_64.dll+0xb5db]
#
# No core dump will be written. Minidumps are not enabled by default on client versions of Windows
#
# An error report file with more information is saved as:
# C:\Users\anand\AppData\Local\Temp\\hs_err_pid9540.log
#
# If you would like to submit a bug report, please visit:
#   http://bugreport.java.com/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#

Re: having problem to upload code on stm32f103c with ftdi

Posted: Fri Dec 22, 2017 6:55 pm
by MAnand59
Hey,
I figured out the solution myself.all i did was that i installed st link utility on my pc and updated the firmware of my st link, and that's it done now it works 😅