[PARTIALLY SOLVED] maple mini com port not showing. URGENT

Post Reply
arkabhowmick
Posts: 7
Joined: Tue Jul 25, 2017 3:44 pm

[PARTIALLY SOLVED] maple mini com port not showing. URGENT

Post by arkabhowmick » Tue Jul 25, 2017 4:21 pm

I just uploaded a nokia 5110 lcd sketch to maple mini via arduino ide.
i used pins 27,28,29,30,31 for spi connections.
After it was done uploading,
whenever i plugged in the maple mini to my computer, the com port is not being detected(no error is also being shown in com port device manager).
i hear 2 sounds one after another when i plug in the maple mini.(one for being detected and one for being plugged out).
Please help. URGENT.
:| :(

stevestrong
Posts: 1749
Joined: Mon Oct 19, 2015 12:06 am
Location: Munich, Germany

Re: maple mini com port not showing. URGENT

Post by stevestrong » Tue Jul 25, 2017 4:51 pm

Try a simple blinky sketch with serial output. If it works, then your software is the problem.
You should be able to upload if you press reset when the upload starts (check the Arduino message window).

arkabhowmick
Posts: 7
Joined: Tue Jul 25, 2017 3:44 pm

Re: maple mini com port not showing. URGENT

Post by arkabhowmick » Tue Jul 25, 2017 5:20 pm

but how to upload sketch when com port is not showing ....neither in arduino ide nor in device manager .. :|

arkabhowmick
Posts: 7
Joined: Tue Jul 25, 2017 3:44 pm

Re: maple mini com port not showing. URGENT

Post by arkabhowmick » Tue Jul 25, 2017 5:27 pm

Thank you very muchhhhhhh :D :) :lol: :mrgreen: it is working..... when uploading sketch i pressed reset...and now the blink sketch works... thank you thank you...

arkabhowmick
Posts: 7
Joined: Tue Jul 25, 2017 3:44 pm

Re: maple mini com port not showing. URGENT

Post by arkabhowmick » Tue Jul 25, 2017 5:28 pm

can you explain me what happened ?

vitor_boss
Posts: 61
Joined: Wed Apr 19, 2017 9:50 am

Re: maple mini com port not showing. URGENT

Post by vitor_boss » Mon Aug 07, 2017 12:38 am

Same problem here with libmaple core, blink works but serial USB don't.

With STM32GENERIC serial USB works.
Any ideas? :?:

stevestrong
Posts: 1749
Joined: Mon Oct 19, 2015 12:06 am
Location: Munich, Germany

Re: maple mini com port not showing. URGENT

Post by stevestrong » Mon Aug 07, 2017 7:59 am

@vitor, how do you upload?
Have you tried to press reset at upload time, when the appropriate message appears in Arduino IDE?

vitor_boss
Posts: 61
Joined: Wed Apr 19, 2017 9:50 am

Re: maple mini com port not showing. URGENT

Post by vitor_boss » Mon Aug 07, 2017 11:31 am

Yes, upload using DFU on 2.0 bootloader. windows says DEVICE_DESCRIPTOR_FAILURE

User avatar
RogerClark
Posts: 7187
Joined: Mon Apr 27, 2015 10:36 am
Location: Melbourne, Australia
Contact:

Re: [PARTIALLY SOLVED] maple mini com port not showing. URGENT

Post by RogerClark » Fri Aug 18, 2017 11:01 am

This thread seems to be a zombie

Please confirm if you still have an issue, otherwise the thread will be deleted as it does not help the community to have open long term open yet dead threads

Post Reply