SdFat not working in Visual Micro ide

Working libraries, libraries being ported and related hardware
castortiu
Posts: 59
Joined: Tue Nov 07, 2017 8:34 am
Location: Seattle, WA

Re: SdFat not working in Visual Micro ide

Post by castortiu » Tue Nov 14, 2017 3:33 pm

For some reason it doesn't see the function implementation.

Since STM is not multitasking I fixed myself implementing the method on the .ino file

Void yield ()
{
}

visual_micro
Posts: 3
Joined: Mon May 11, 2015 10:25 am

SOLVED: Re: SdFat not working in Visual Micro ide

Post by visual_micro » Sun Jan 28, 2018 3:11 am

Hi All,

Thanks for the patience.

This issue was because Visual Micro also supports older Arduino IDE versions that use a "wprogram.h" instead of "arduino.h" during the build process.

In the case of the STM32 boards the maple core contained both a wprogram.h and an arduino.h. Visual Micro used the wprogram.h but in the next release uses the arduino.h which resolves this issue.

The wprogram.h in the maple core differs slightly from the arduno.h and does not contain a definition for the delay() function.

The next release of Visual Micro is due over the next few days with the fix.

Thanks for your patience.

Tim @ Visual Micro
http://www.visualmicro.com/forums/

User avatar
BennehBoy
Posts: 501
Joined: Thu Jan 05, 2017 8:21 pm
Location: Yorkshire
Contact:

Re: SdFat not working in Visual Micro ide

Post by BennehBoy » Sun Jan 28, 2018 12:09 pm

Slight aside: I've been experimenting with MS VSCode...

Installing it, the C/C++ extension, and MS's Arduino extension, I've been able to compile for any of the cores that my Arduino installation has installed, directly from VSCode - it's also git integrated, and the context sensitive editor is really good.

Seriously thinking of switching over to it from the default IDE editor.
-------------------------------------
https://github.com/BennehBoy

Jimbo13
Posts: 19
Joined: Sun Jan 01, 2017 5:10 pm
Location: Essex UK

Re: SdFat not working in Visual Micro ide

Post by Jimbo13 » Sun Jan 28, 2018 5:05 pm

Hi BennehBoy, I looked at VScode but I am not sure why I would use it as https://www.visualstudio.com/vs/community/ is free also as is the Visual Micro add on: http://www.visualmicro.com/
I also dont want to have to learn anything new, to do the same job.

I think Visual Micro will meet all your needs.

zmemw16
Posts: 1674
Joined: Wed Jul 08, 2015 2:09 pm
Location: St Annes, Lancs,UK

Re: SdFat not working in Visual Micro ide

Post by zmemw16 » Sun Jan 28, 2018 6:50 pm

and what platforms does that run on ?
srp

User avatar
BennehBoy
Posts: 501
Joined: Thu Jan 05, 2017 8:21 pm
Location: Yorkshire
Contact:

Re: SdFat not working in Visual Micro ide

Post by BennehBoy » Sun Jan 28, 2018 10:10 pm

Jimbo13 wrote:
Sun Jan 28, 2018 5:05 pm
Hi BennehBoy, I looked at VScode but I am not sure why I would use it as https://www.visualstudio.com/vs/community/ is free also as is the Visual Micro add on: http://www.visualmicro.com/
I also dont want to have to learn anything new, to do the same job.

I think Visual Micro will meet all your needs.
Yeah but VSC is complete bloat so I wanted to avoid it. Point being, it just worked out the box.
-------------------------------------
https://github.com/BennehBoy

Post Reply