$10 O-Scope revisited

What are you developing?
User avatar
ahull
Posts: 1544
Joined: Mon Apr 27, 2015 11:04 pm
Location: Sunny Scotland
Contact:

Re: $10 O-Scope revisited

Post by ahull » Thu Apr 20, 2017 1:38 pm

efftek wrote:@Andy Hull, I would like to send one of my boards to you so you can play with it and see what you can come up with using a TFT shield rather than a SPI TFT. If you would be interested, please PM me. I'll fit the components, you just need a screen.
Board received, thanks. :D Blinkenlights are a-blinking, so it appears to be working. I'll pop a display and a button cell on it as soon as I get a chance.
- Andy Hull -

User avatar
ahull
Posts: 1544
Joined: Mon Apr 27, 2015 11:04 pm
Location: Sunny Scotland
Contact:

Re: $10 O-Scope revisited

Post by ahull » Thu Apr 20, 2017 2:25 pm

BW is there a schematic? Although it looks pretty self explanatory, it might avoid me making any smoke releasing assumptions.
- Andy Hull -

User avatar
efftek
Posts: 76
Joined: Tue Jan 10, 2017 9:42 pm
Location: UK / Cyprus
Contact:

Re: $10 O-Scope revisited

Post by efftek » Thu Apr 20, 2017 3:31 pm

ahull wrote:BW is there a schematic? Although it looks pretty self explanatory, it might avoid me making any smoke releasing assumptions.
There is, but I don't have access as I'm at my daughters house. However, the pins marked 5V And 0V on the board are all correct as are the labels next to the blue pill and the analog input pins. It's just the digital pin numbering I cocked up on the silk screen and they are only in the reverse order. I'll put a schematic on here tomorrow.

Happy playing.

Steve.

User avatar
ahull
Posts: 1544
Joined: Mon Apr 27, 2015 11:04 pm
Location: Sunny Scotland
Contact:

Re: $10 O-Scope revisited

Post by ahull » Thu Apr 20, 2017 10:44 pm

.rorrim eht ni ti ta kool ot evah ot gnitcepxe t'nsaw I ,ddo tib a s'taht lleW

Image

.. also placing the bluepill on the same side of the board as the display... you are right.. it was not a good move.

Other than those two issues.. its working fine. :D
- Andy Hull -

User avatar
Rick Kimball
Posts: 951
Joined: Tue Apr 28, 2015 1:26 am
Location: Eastern NC, US
Contact:

Re: $10 O-Scope revisited

Post by Rick Kimball » Fri Apr 21, 2017 2:03 am

I guess you weren't named Leonardo in a past life : )
-rick

User avatar
rexnanet
Posts: 190
Joined: Wed Mar 16, 2016 10:34 am

Re: $10 O-Scope revisited

Post by rexnanet » Fri Apr 21, 2017 8:28 am

ThunderOwl wrote:Hello again here.
Today I did some fancy thing I was planning for some time. Replaced chip on one of my "BluePill" boards with STM32F303 microcontroller.
Sure I am not the first one doing that, I know. Many have thoughts that would be nice if chinese manufacturers would make cheap "F303 Pills", but there are none (AFAIK). So, we can make one, pinouts are the same as F103. Here my pictures:
http://bildites.lv/a/pjuhvaf5#6jv5nwen
One of pics shows this board running tomeko.net "MiniScope v2d" firmware.
I thought, maybe that is something to consider here in our "O-Scope" variations. If someone write code for F303 (better ADCs, etc), with such BluePill conversion we have "drop-in, pin-compatible" hardware.
Technically, I did "blow off" old chip with hot air pistol, and soldered STM32F303CBT6 in place.
Thoughts, anyone? :)
Just got my brand new F303's :)
Have to desolder ( "blow off" :D or X-acto cut) the F103's and solder the new ones :)

I haven't checked yet but is there "arduino" support for the F303?

P.S. I've also got the F429's soldered on an adapter to start messing with them :D but that's another story :)

User avatar
efftek
Posts: 76
Joined: Tue Jan 10, 2017 9:42 pm
Location: UK / Cyprus
Contact:

Re: $10 O-Scope revisited

Post by efftek » Sun Apr 23, 2017 3:08 pm

Pin config for the GP Board (with correct labels). If my memory was bigger than 32k, Id have remembered to do it on Friday!

Steve
GP01 pins.jpg
GP01 pins.jpg (164.99 KiB) Viewed 605 times

User avatar
Rick Kimball
Posts: 951
Joined: Tue Apr 28, 2015 1:26 am
Location: Eastern NC, US
Contact:

Re: $10 O-Scope revisited

Post by Rick Kimball » Sun Apr 23, 2017 7:38 pm

Why do people here constantly pollute the threads with non related questions? It is getting ridiculous now.

... Looks around for a moderator control panel and the delete post button ...
-rick

User avatar
efftek
Posts: 76
Joined: Tue Jan 10, 2017 9:42 pm
Location: UK / Cyprus
Contact:

Re: $10 O-Scope revisited

Post by efftek » Tue Apr 25, 2017 9:20 pm

Rick Kimball wrote:Why do people here constantly pollute the threads with non related questions? It is getting ridiculous now.
Who are you referring to Rick?

User avatar
martinayotte
Posts: 1194
Joined: Mon Apr 27, 2015 1:45 pm

Re: $10 O-Scope revisited

Post by martinayotte » Tue Apr 25, 2017 9:36 pm

efftek wrote:Who are you referring to Rick?
It is clear ! The post above Rick's post is clearly shows that it ask for help about st-link issue, nothing related with the O-Scope thread.
And the funny thing is that there is even a st-link section on the forum with tons of thread.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest